Other Blank screen when starting window manager

Hi everyone, I'm trying to breath some life into an old Macbook:

$ inxi
CPU: dual core Intel Core2 Duo P7350 (-MCP-) speed: 1990 MHz OS: FreeBSD 13.0-RELEASE amd64
Up: 3h 6m Mem: 278.1/1739.0 MiB (16.0) Storage: 232.89 GiB (3.5% used) Procs: 51 Shell: sh
inxi: 3.3.11
$ inxi -G
  Device-1: NVIDIA C79 [GeForce 9400M G] driver: vgapci
  Display: server: X.org 1.20.14 driver: loaded: nvidia tty: 135x42
  Message: Advanced graphics data unavailable in console. Try -G --display

I installed nvidia-driver-340 and it seems to work well: when I type startx, the nvidia splash screen appears, twm starts, and X is working. But when I try startx with any other window manager (tried cinnamon and enlightenment), after the nvidia logo I get only a blank screen. The contents of /var/log/Xorg.0.log seem to imply that X has terminated immediately, the last few lines being

[   359.937] (**) vendor 0x0461 USB Optical Mouse: (accel) selected scheme none/0
[   359.937] (**) vendor 0x0461 USB Optical Mouse: (accel) acceleration factor: 2.000
[   359.937] (**) vendor 0x0461 USB Optical Mouse: (accel) acceleration threshold: 4
[   359.943] (II) event8  - vendor 0x0461 USB Optical Mouse, class 0/0, rev 2.00/2.00, addr 6: is tagged by udev as: Mouse
[   359.947] (II) event8  - vendor 0x0461 USB Optical Mouse, class 0/0, rev 2.00/2.00, addr 6: device is a pointer
[   360.249] (II) event0  - System mouse: device removed
[   360.249] (II) event1  - System keyboard multiplexer: device removed
[   360.250] (II) event3  - Power Button: device removed
[   360.250] (II) event4  - Sleep Button: device removed
[   360.250] (II) event6  - Apple Internal Keyboard: device removed
[   360.250] (II) event8  - vendor 0x0461 USB Optical Mouse, class 0/0, rev 2.00/2.00, addr 6: device removed
[   360.282] (II) UnloadModule: "libinput"
[   360.282] (II) UnloadModule: "libinput"
[   360.282] (II) UnloadModule: "libinput"
[   360.282] (II) UnloadModule: "libinput"
[   360.282] (II) UnloadModule: "libinput"
[   360.282] (II) UnloadModule: "libinput"
[   361.376] (II) NVIDIA(GPU-0): Deleting GPU-0
[   361.378] (II) Server terminated successfully (0). Closing log file.
Can anyone tell me why cinnamon/enlightenment won't work, while twm works fine?
Last edited:
startx command uses what's in your .xinitrc file.
startx also implies that you are not using a graphical login manager and are booting to a console.
Some of these other things are more Desktop Environment than Window Manager so you should put a different command in .xinitrc.
What I would do is create $HOME/.xinitrc with a single line:
exec /usr/local/bin/xterm

That gives you an xterm, with no decorations, but will let you start different windowmanagers from that xterm.
say you wanted to test WindowMaker: you would simply type in /usr/local/bin/wmaker & in that xterm.
Different commands would start different things. Once you figure that out, change that single line.
Thanks everyone for your responses. Some updates:

CuatroTorres Yes, my user was already in the video, wheel and operator groups.

T-Daemon Yes, that's exactly what I did. I got a blank screen after the NVidia logo in both cases, and after waiting for a long time, nothing else happened. Logs indicated that X had already exited.

mer I finally resolved this problem by writing

exec enlightenment-start

in .xinitrc and then startx without any parameters. This now works. I still don't know why specifying the window manager as a parameter didn't work, but I'm happy to use it this way.

An annoying problem is that once X starts, the console and virtual terminals are no longer visible. I can still <CTRL>-<ALT>-<Fn> to them, start commands blindly and they are running, but can't see any output. I've seen several other posts reporting the same issue, which is apparently caused by vt.

In my setup I have the same resolution, 1280x800, for both the virtual terminals and X. My understanding is that KMS should enable switching between different modes seamlessly, but in my case that's not even necessary, since it's the same mode. Is this correct? Could anyone explain/point to and explanation what KMS is for and how it affects vt?
If you have nvidia, try adding the following to the /boot/loader.conf and rebooting. It basically puts the text console into "text mode" so you lose higher resolution when not in X, but you may not care. I don't.

mer Thanks for the tip; I tried it but it didn't work. In fact I didn't see any changes in the fonts at boot time, and the splash screen still looks graphical, with the FreeBSD logo rendered in smooth characters, rather than ASCII art. Am I missing something? Is it possible that the hardware forces graphical mode?