• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Asus EEE PC 1000H

ccc

Aspiring Daemon

Thanks: 11
Messages: 621

#27
I hope freeBSD 8.0 will support these module:

ethernet adapter: Atheros AR8121/AR8113/AR8114 PCI-E
wireless: RALINK, it needs rt2860 module
 

ccc

Aspiring Daemon

Thanks: 11
Messages: 621

#28
I've installed freeBSD 7.2 on my eeepc 1000H.
Atheros wired was detected automatically:
Code:
# ifconfig -a
ale0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=319b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,WOL_MCAST,WOL_MAGIC>
        ether 00:24:32:28:cc:4e
        inet 192.168.2.23 netmask 0xffffff00 broadcast 192.168.2.255
        media: Ethernet autoselect (100baseTX <full-duplex>)
        status: active
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2
        inet6 ::1 prefixlen 128
        inet 127.0.0.1 netmask 0xff000000
rt2860 module is still missing at the GENERIC kernel from 7.2.

Perhaps I'll try to create a driver module from windows using ndisgen:.
firmware and windows driver can be downloadet at:
http://www.ralinktech.com.tw/data/drivers/RT2860_Firmware_V11.zip

greetings
ccc
 

ccc

Aspiring Daemon

Thanks: 11
Messages: 621

#30
mathuin said:
I tried this earlier in the thread and had no success -- hopefully you will succeed where I failed. It's not in 8.0-BETA2 either. :-(
Where we can send a request to maintainers to put the ral module into new 8.0 kernel?
 

PaulWebster

Member


Messages: 27

#32
If anyone has any experiance with the openbsd DMA engine and any ideas on howto port it over, would be more than welcome :)
 

PaulWebster

Member


Messages: 27

#33
Oh and a deffinate no no on the ndis idea, I have tried it with multiple drivers and the best result I received was it not working, elsewhere it crashs. May also be worth noting at this point that I have also tried it on every patchset release of 8.x and 7.x so the rumours that are floating about on google about it working are lies or someone has identified the card they are using incorrectly.
 

thuglife

Active Member

Thanks: 41
Messages: 160

#34
Hello

I have 1000H and ndis works pretty well.

Code:
>pciconf -lv 
hostb0@pci0:0:0:0:	class=0x060000 card=0x83401043 chip=0x27ac8086 rev=0x03 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Mobile 945GME Express Processor to DRAM Controller'
    class      = bridge
    subclass   = HOST-PCI
vgapci0@pci0:0:2:0:	class=0x030000 card=0x83401043 chip=0x27ae8086 rev=0x03 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Mobile 945 Express Chipset Family'
    class      = display
    subclass   = VGA
vgapci1@pci0:0:2:1:	class=0x038000 card=0x83401043 chip=0x27a68086 rev=0x03 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = 'Mobile 945GM/GU Express Integrated Graphics Controller'
    class      = display
hdac0@pci0:0:27:0:	class=0x040300 card=0x831a1043 chip=0x27d88086 rev=0x02 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82801G (ICH7 Family) High Definition Audio'
    class      = multimedia
    subclass   = HDA
pcib1@pci0:0:28:0:	class=0x060400 card=0x830f1043 chip=0x27d08086 rev=0x02 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = '82801G (ICH7 Family) PCIe Root Port'
    class      = bridge
    subclass   = PCI-PCI
pcib2@pci0:0:28:1:	class=0x060400 card=0x830f1043 chip=0x27d28086 rev=0x02 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = '82801G (ICH7 Family) PCIe Root Port'
    class      = bridge
    subclass   = PCI-PCI
pcib3@pci0:0:28:3:	class=0x060400 card=0x830f1043 chip=0x27d68086 rev=0x02 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = '82801G (ICH7 Family) PCIe Root Port'
    class      = bridge
    subclass   = PCI-PCI
uhci0@pci0:0:29:0:	class=0x0c0300 card=0x830f1043 chip=0x27c88086 rev=0x02 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82801G (ICH7 Family) USB Universal Host Controller'
    class      = serial bus
    subclass   = USB
uhci1@pci0:0:29:1:	class=0x0c0300 card=0x830f1043 chip=0x27c98086 rev=0x02 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82801G (ICH7 Family) USB Universal Host Controller'
    class      = serial bus
    subclass   = USB
uhci2@pci0:0:29:2:	class=0x0c0300 card=0x830f1043 chip=0x27ca8086 rev=0x02 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82801G (ICH7 Family) USB Universal Host Controller'
    class      = serial bus
    subclass   = USB
uhci3@pci0:0:29:3:	class=0x0c0300 card=0x830f1043 chip=0x27cb8086 rev=0x02 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82801G (ICH7 Family) USB Universal Host Controller'
    class      = serial bus
    subclass   = USB
ehci0@pci0:0:29:7:	class=0x0c0320 card=0x830f1043 chip=0x27cc8086 rev=0x02 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82801G (ICH7 Family) USB 2.0 Enhanced Host Controller'
    class      = serial bus
    subclass   = USB
pcib4@pci0:0:30:0:	class=0x060401 card=0x830f1043 chip=0x24488086 rev=0xe2 hdr=0x01
    vendor     = 'Intel Corporation'
    device     = '82801 Family (ICH2/3/4/5/6/7/8/9-M) Hub Interface to PCI Bridge'
    class      = bridge
    subclass   = PCI-PCI
isab0@pci0:0:31:0:	class=0x060100 card=0x830f1043 chip=0x27b98086 rev=0x02 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82801GBM (ICH7-M) LPC Interface Controller'
    class      = bridge
    subclass   = PCI-ISA
atapci0@pci0:0:31:2:	class=0x010180 card=0x830f1043 chip=0x27c48086 rev=0x02 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '82801GBM/GHM (ICH7-M Family) Serial ATA Storage Controller'
    class      = mass storage
    subclass   = ATA
ale0@pci0:3:0:0:	class=0x020000 card=0x83241043 chip=0x10261969 rev=0xb0 hdr=0x00
    vendor     = 'Attansic (Now owned by Atheros)'
    device     = 'PCI-E ETHERNET CONTROLLER  (AR8121/AR8113 )'
    class      = network
    subclass   = ethernet
ndis0@pci0:1:0:0:	class=0x028000 card=0x27901814 chip=0x07811814 rev=0x00 hdr=0x00
    vendor     = 'Ralink Technology, Corp'
    device     = 'Wireless (RT2860/RT2890)'
    class      = network
Code:
> ifconfig
ale0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=319b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4,WOL_MCAST,WOL_MAGIC>
	ether 00:24:8c:4e:89:cd
	media: Ethernet autoselect (none)
	status: no carrier
ndis0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 2290
	ether 00:22:43:6c:fd:dc
	media: IEEE 802.11 Wireless Ethernet autoselect mode 11g
	status: associated
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
	options=3<RXCSUM,TXCSUM>
	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3 
	inet6 ::1 prefixlen 128 
	inet 127.0.0.1 netmask 0xff000000 
wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
	ether 00:22:43:6c:fd:dc
	inet 192.168.0.17 netmask 0xffffff00 broadcast 192.168.0.255
	media: IEEE 802.11 Wireless Ethernet OFDM/24Mbps mode 11g
	status: associated
	ssid Home2 channel 11 (2462 Mhz 11g) bssid 00:05:59:0c:47:60
	country US authmode WPA privacy OFF txpower 0 bmiss 7 mcastrate 9
	mgmtrate 9 scanvalid 60 protmode CTS roaming MANUAL bintval 0
I have the following lines in my rc.conf
Code:
defaultrouter="192.168.0.1"
hostname="minibot.cybertron.local"

wlans_ndis0="wlan0"
ifconfig_wlan0="WPA inet 192.167.0.17 netmask 255.255.255.0"
 

PaulWebster

Member


Messages: 27

#36
I would love to know what driver also, could you possible upload them and provide a link?
 

thuglife

Active Member

Thanks: 41
Messages: 160

#38
Code:
> uname -a
FreeBSD minibot.cybertron.local 8.0-CURRENT-200906 FreeBSD 8.0-CURRENT-200906 #2: Mon Jun 29 04:57:24 EEST 2009     root@minibot.cybertron.local:/usr/obj/usr/src/sys/MINIBOT  i386
Code:
#ndisgen rt2860.inf rt2860.sys
I 've installed the drivers in a XP VM and got rt2860.inf and rt2860.sys, i 've also used the firmware.

Ensure that you have wireless on from the bios.
 

mathuin

Member


Messages: 45

#40
Thank you so much, thuglife. :) I installed your drivers and had near-complete success.

The only problem I had was that DHCP doesn't do the right thing when the machine boots. I have to start it after logging in with this command:

Code:
sudo /etc/rc.d/dhclient start wlan0
And it gets an address easy as pie. Wow. Thanks again.

Any ideas why DHCP doesn't work on boot?
 

PaulWebster

Member


Messages: 27

#41
RE: dhcp not working

I am just making world on my eeepc to test these drivers out, but try marking the interface as 'up' before running dhclient
 

PaulWebster

Member


Messages: 27

#42
RE: confirmation Latest build

I can confirm that the driver does work with the latest CVS of current as of 2 hours ago.

I just associated to my WPA1 AP and succesfully used dhclient to receive an IP! I have no idea why the hell this did not work last time I tried it -_-, anyhow not tried actually donig anything with it ill post in a few.
 

PaulWebster

Member


Messages: 27

#45
May possible try cleaning this one up

As it is blatently obious that the errors about rate.bin and Zw(Write|Create|Read)File are not neccesary I might try and add them to the ndis sources, if im reading up on what they do... its simply creating a directory without some safety procedures..
 

PaulWebster

Member


Messages: 27

#46
Ok quick check, put some pressure on it and its still stable, created a 1G file on my router/gateway 'dd if=/dev/random of=/home/paul/1GFILE bs=1M count=1000'

This is only a G standard network and I have an asus eeepc 1000 (ssd) the download speed over ftp, via wireless was 6.9M-7M/s to start with before stabilizing at 3.5M/s, This again though is an SSD laptop which the bottleneck is likely the Disks not the network. All is still stable. I also ran a torrent from the machine in question and seen no diminished performance.
 

PaulWebster

Member


Messages: 27

#47
RE: potential problem

it seems the driver has issues with small packets, that is simply transactions in one tcp stream that are of low bandwidth, this driver will timeout on cvsup but work with portsnap etc...
 

mathuin

Member


Messages: 45

#48
Yeah, I noticed bad performance with instant messaging. Hmm, wonder why? I wonder if it'd help to find copies of those two files?