Problem installing from ports

Installing and maintaining the FreeBSD Ports Collection or FreeBSD Packages (i.e. third party software).

Problem installing from ports

Postby Majid » 28 Dec 2010, 21:51

I have tried to install php 5 and firefox 3.6 from ports. Both attempts failed with similar (as far as I see) condition. The error from installing php follows. What is wrong?

Code: Select all
===>   php5-5.3.4 depends on file: /usr/local/bin/autoconf-2.68 - not found
===>    Verifying install for /usr/local/bin/autoconf-2.68 in /usr/ports/devel/a
utoconf
===>  Building for autoconf-2.68
gmake  all-recursive
gmake[1]: Entering directory `/usr/ports/devel/autoconf/work/autoconf-2.68'
Making all in bin
gmake[2]: Entering directory `/usr/ports/devel/autoconf/work/autoconf-2.68/bin'
autom4te_perllibdir='..'/lib AUTOM4TE_CFG='../lib/autom4te.cfg'         ../bin/a
utom4te -B '..'/lib -B '..'/lib         --language M4sh --cache '' --melt ./auto
conf.as -o autoconf.in
autoconf.as:1: /usr/local/bin/gm4: Warning: Excess arguments to built-in `_m4_po
pdef' ignored
autom4te: /usr/local/bin/gm4 failed with exit status: 1
gmake[2]: *** [autoconf.in] Error 1
gmake[2]: Leaving directory `/usr/ports/devel/autoconf/work/autoconf-2.68/bin'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/devel/autoconf/work/autoconf-2.68'
gmake: *** [all] Error 2
*** Error code 1

Stop in /usr/ports/devel/autoconf.
*** Error code 1

Stop in /usr/ports/lang/php5.
*** Error code 1

Stop in /usr/ports/lang/php5.
Majid
Junior Member
 
Posts: 6
Joined: 28 Dec 2010, 06:15

Postby graudeejs » 28 Dec 2010, 22:31

Read [file]/usr/ports/UPDATING[/file]
It covers this issue (tip search for autotools)
User avatar
graudeejs
Style(9) Addict
 
Posts: 4591
Joined: 16 Nov 2008, 23:23
Location: Riga, Latvia

Postby GhettoBSD » 21 Jan 2011, 16:28

Majid: did you ever get this figured out? I'm having the same issue and just can't get it to work. I'm working with the PC-BSD version and somethings are just slightly different so I'm not sure where my problem can be.

And to save some the hassle of reading:

[INDENT]20101208:
AFFECTS: autotools
AUTHOR: autotools@FreeBSD.org

Another stage in the autotools cleanup that reduces tree churn whilst
updating components, a number of ports have now moved to non-versioned
locations since there is now only the concept of legacy and current
versions.

# portmaster -o devel/autoconf devel/autoconf268
# portmaster -o devel/automake devel/automake111
# portmaster -o devel/libtool devel/libtool22
# portmaster -o devel/libltdl devel/libltdl22

substitute 'portupgrade' for 'portmaster' accordingly if that's your
your upgrade tool of choice.[/INDENT]
You can never say never and never say always.
Check out the new GhettoBSD.org site. Now with Web 3.0!
GhettoBSD
Junior Member
 
Posts: 38
Joined: 27 Jul 2009, 16:31

Postby skalik » 09 May 2012, 10:54

I have the same error. I was able to install [FILE]autoconf268[/FILE] after upgrading the [FILE]m4[/FILE] port ([FILE]make deinstall[/FILE], [FILE]make install[/FILE]).
skalik
Junior Member
 
Posts: 1
Joined: 09 May 2012, 10:52


Return to Installation and Maintenance of FreeBSD Ports or Packages

Who is online

Users browsing this forum: No registered users and 1 guest