1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem installing from ports

Discussion in 'Installation and Maintenance of Ports or Packages' started by Majid, Dec 28, 2010.

  1. Majid

    Majid New Member

    Thanks Received:
    I have tried to install php 5 and firefox 3.6 from ports. Both attempts failed with similar (as far as I see) condition. The error from installing php follows. What is wrong?

    ===>   php5-5.3.4 depends on file: /usr/local/bin/autoconf-2.68 - not found
    ===>    Verifying install for /usr/local/bin/autoconf-2.68 in /usr/ports/devel/a
    ===>  Building for autoconf-2.68
    gmake  all-recursive
    gmake[1]: Entering directory `/usr/ports/devel/autoconf/work/autoconf-2.68'
    Making all in bin
    gmake[2]: Entering directory `/usr/ports/devel/autoconf/work/autoconf-2.68/bin'
    autom4te_perllibdir='..'/lib AUTOM4TE_CFG='../lib/autom4te.cfg'         ../bin/a
    utom4te -B '..'/lib -B '..'/lib         --language M4sh --cache '' --melt ./auto
    conf.as -o autoconf.in
    autoconf.as:1: /usr/local/bin/gm4: Warning: Excess arguments to built-in `_m4_po
    pdef' ignored
    autom4te: /usr/local/bin/gm4 failed with exit status: 1
    gmake[2]: *** [autoconf.in] Error 1
    gmake[2]: Leaving directory `/usr/ports/devel/autoconf/work/autoconf-2.68/bin'
    gmake[1]: *** [all-recursive] Error 1
    gmake[1]: Leaving directory `/usr/ports/devel/autoconf/work/autoconf-2.68'
    gmake: *** [all] Error 2
    *** Error code 1
    Stop in /usr/ports/devel/autoconf.
    *** Error code 1
    Stop in /usr/ports/lang/php5.
    *** Error code 1
    Stop in /usr/ports/lang/php5.
  2. graudeejs

    graudeejs Well-Known Member

    Thanks Received:
    Read /usr/ports/UPDATING
    It covers this issue (tip search for autotools)
  3. GhettoBSD

    GhettoBSD New Member

    Thanks Received:
    Majid: did you ever get this figured out? I'm having the same issue and just can't get it to work. I'm working with the PC-BSD version and somethings are just slightly different so I'm not sure where my problem can be.

    And to save some the hassle of reading:

    AFFECTS: autotools
    AUTHOR: autotools@FreeBSD.org

    Another stage in the autotools cleanup that reduces tree churn whilst
    updating components, a number of ports have now moved to non-versioned
    locations since there is now only the concept of legacy and current

    # portmaster -o devel/autoconf devel/autoconf268
    # portmaster -o devel/automake devel/automake111
    # portmaster -o devel/libtool devel/libtool22
    # portmaster -o devel/libltdl devel/libltdl22

    substitute 'portupgrade' for 'portmaster' accordingly if that's your
    your upgrade tool of choice.​
  4. skalik

    skalik New Member

    Thanks Received:
    I have the same error. I was able to install autoconf268 after upgrading the m4 port (make deinstall, make install).