Zpool Reserved Name Error

thedude

New Member


Messages: 11

Alright, let me say i'm sorry if this has been discussed, but i could not find anything talking about a problem like this...

So i have a cold right now, and i'm a little out of it, but i needed to setup my backup server and i only have so much time before i go back to school, so i just decided to get it up and running.
Well, since this would just be a backup for my file server i figured i might as well give zfs a shot, and see how it works. After doing some reading, i logged into the machine, and typed the following command
Code:
# zpool create radiz /dev/ad4 /dev/ad12 /dev/ad16
I got no message, so i figured it was fine, but i decided to check the status just to make sure and this is my output:
Code:
# zpool status
  pool: radiz
 state: ONLINE
 scrub: none requested
config:

	NAME        STATE     READ WRITE CKSUM
	radiz       ONLINE       0     0     0
	  ad4       ONLINE       0     0     0
	  ad12      ONLINE       0     0     0
	  ad16      ONLINE       0     0     0

errors: No known data errors
This is the point i realized that i forgot to provide a name for the pool and that it instead gave the pool the _reserved_ name raidz. Next thing i did was try to destroy the pool, but that didn't work out too well
Code:
# zpool destroy raidz
cannot open 'raidz': name is reserved
I also tried removing the devices, but it gave me the same error. Anytime i try to reference the pool i get the same "name is reserved" error...

Now i'm kind of lost about what to do at the moment, and i've been having some trouble finding anything on google, so i would appreciate any advice or suggestions as to what i can do to fix this problem
 
OP
OP
T

thedude

New Member


Messages: 11

alright, now i know something is wrong with me, usually i would have noticed this long ago... the name i gave the pool was radiz and not raidz like i had thought.
Sorry, for the pointless post, i think i'm going to go laid down instead of work, i'm probably just going to do more harm then good in my current condition...
 
Top