Solved ZFS problem, no more space left, directories gone


I think I have a big problem with ZFS...

Until today everything worked fine but then some of my services (I think it was the backup tool) went crazy and started writing more and more files into /var/. That lead to a full reboot of the system and after that some of the important files in /var were gone (for example the www directory).
Now it looks like this:
# zfs list
zsystem          33,7G      0  9,36G  /
zsystem/tmp      1,91M      0  1,91M  /tmp
zsystem/var      20,4G      0  20,4G  /var
zsystem/var/log  16,9M      0  16,9M  /var/log
zsystem/var/tmp   712K      0   712K  /var/tmp

With df -h /var I can not detect any big files in /var. And I also can not understand why /var/db and /var/www were gone.
I have a snapshot on zsystem, but starting
# zfs rollback zsystem@yesterday
the systems hangs... ssh access is no longer possible, no HDD activity. I have to hard reboot.

Please help me... I need to recover the things ins /var/www and /var/db

Yes, it seems so, but does that result in loosing subdirectories in a dataset?
I read about the problem to remove files in ZFS if all the space is used, so what can I do now? Should I try to add a new device (maybe USB-Stick) to the pool to increase the size and hopefully recovere my data?
Sorry, I have no enough experience with ZFS, please wait for other answers.
But I suspect that a failed snapshot rollback could result in an incomplete tree.
Again, I know there many ZFS competent members in this forum, just wait.
I solved the problem by adding a USB-Stick as cache device to the pool, then I ran "scrub" and all files were back again :)
After that I removed the big files to free some bytes again. At last I remove the cache again.

Simple... but it`s a little bit strange that ZFS don`t show some files anymore if the space is at zero level.