Solved XOrg do not work with AMD (again)

YuryG

Aspiring Daemon

Reaction score: 29
Messages: 503

Recently I've upgraded 11-STABLE (the upgrade with clang-8.0). And my XOrg desktop stopped working. Now it loads only VESA with ridiculous and unusable colours (256???) and resolution.
Xorg.0.log
Part of dmesg.boot
Code:
[drm] radeon kernel modesetting enabled.
drmn0: <drmn> on vgapci0
vgapci0: child drmn0 requested pci_enable_io
vgapci0: child drmn0 requested pci_enable_io
[drm] initializing kernel modesetting (RS780 0x1002:0x9616 0x1043:0x8388 0x00).
[drm] register mmio base: 0xFE9F0000
[drm] register mmio size: 65536
[drm:radeon_device_init] Unable to find PCI I/O BAR
[drm:radeon_atombios_init] Unable to find PCI I/O BAR; using MMIO for ATOM IIO
ATOM BIOS: B27722_RS780C
drmn0: VRAM: 256M 0x00000000C0000000 - 0x00000000CFFFFFFF (256M used)
drmn0: GTT: 512M 0x00000000A0000000 - 0x00000000BFFFFFFF
[drm] Detected VRAM RAM=256M, BAR=256M
[drm] RAM width 32bits DDR
[drm:radeon_ttm_global_init] Failed setting up TTM memory accounting subsystem.
drmn0: Fatal error during GPU init
[drm] radeon: finishing device.
[TTM] Memory type 2 has not been initialized
device_attach: drmn0 attach returned 12
It worked previously! xf86-video-ati driver is updated as mesa-libs, mesa-dri (still using llvm60, yes?), xorg-server etc.
 

k.jacker

Aspiring Daemon

Reaction score: 469
Messages: 740

Is there any good reason why you are running STABLE and not RELEASE?

Anyway, it looks like you upgraded from 11.1-STABLE to 11.2-STABLE and that you have a Ati HD3200 (RS780) is that correct?
I assume you must have been using the base system's /boot/kernel/readeonkms.ko, correct?

- make sure, you really finished the upgrade and userland and kernel are in sync.
- remove/comment out driver and monitor related sections in xorg.conf and let Xorg handle the autoconfiguration of the kms driver
 

aht0

Active Member

Reaction score: 59
Messages: 183

I believe building kernel and world with clang-8 is not done even in CURRENT yet..
 
OP
Y

YuryG

Aspiring Daemon

Reaction score: 29
Messages: 503

I believe building kernel and world with clang-8 is not done even in CURRENT yet..
You can fetch /usr/src/UPDATING for STABLE and see the latest news, it is migration to Clang-8 .
 
OP
Y

YuryG

Aspiring Daemon

Reaction score: 29
Messages: 503

Is there any good reason why you are running STABLE and not RELEASE?

Anyway, it looks like you upgraded from 11.1-STABLE to 11.2-STABLE and that you have a Ati HD3200 (RS780) is that correct?
I assume you must have been using the base system's /boot/kernel/readeonkms.ko, correct?

- make sure, you really finished the upgrade and userland and kernel are in sync.
- remove/comment out driver and monitor related sections in xorg.conf and let Xorg handle the autoconfiguration of the kms driver
I believe yes, there were reasons to use STABLE more than to be a bit "in future", some of them related to graphics support.

STABLE used not to add point numbers to versions, as far as I can remember. No, 11.2 released on July 2018 and I've made upgrades (more or less successful) much later, so, it should have been 11.2 already. Now I have 11.2-STABLE r346790.
Yes, my graphics is integrated in chipset HD3200.

I had been using graphics/drm-kmod when it was O.K. In rc.conf, as the port recommends, I have kld_list line with /boot/modules/radeonkms.ko.
Now I've discovered these errors in dmesg.boot also:
Code:
32-bit compatibility ldconfig path: /usr/lib32 /usr/local/lib32/compat        
Loading kernel modules:                                                       
anon_inodefs_init:                                                            
link_elf_obj: symbol agp_bind_pages undefined                                 
linker_load_file: Unsupported file type                                       
KLD radeonkms.ko: depends on ttm - not available or version mismatch          
anon_inodefs_uninit:                                                          
linker_load_file: Unsupported file type                                       
kldload: an error occurred while loading the module. Please check dmesg(8) for more details.                                                                  
/etc/rc: WARNING: Unable to load kernel module /boot/modules/radeonkms.ko     
anon_inodefs_init:                                                            
link_elf_obj: symbol agp_bind_pages undefined                                 
anon_inodefs_uninit:                                                          
linker_load_file: Unsupported file type                                       
kldload: an error occurred while loading the module. Please check dmesg(8) for more details.                                                                  
/etc/rc: WARNING: Unable to load kernel module /boot/modules/ttm.ko           
anon_inodefs_init:                                                            
kldload: can't load /boot/modules/linuxkpi_gplv2.ko: module already loaded or in kernel                                                                       
/etc/rc: WARNING: Unable to load kernel module /boot/modules/linuxkpi_gplv2.ko
Setting hostname: ..
Setting up harvesting: [UMA],[FS_ATIME],SWI,INTERRUPT,NET_NG,NET_ETHER,NET_TUN,MOUSE,KEYBOARD,ATTACH,CACHED
So, for some reason, the modules are not loaded.

By the way, is any way to set up VESA properly? (Some errors are seen in my Xorg.0.log, among others is low refresh rate for me, and unusable colours, for example bright green becomes red.)
 
OP
Y

YuryG

Aspiring Daemon

Reaction score: 29
Messages: 503

O.K. The problem is solved. It was in strange custom kernel options. You must have agp, must not have drm and COMPAT_LINUXKPI in kernel.

So, only secondary question remains ununswered about options for good VESA configuration.
 
Top