xauth: file /home/niatross/.serverauth.18249 does not exist

Niatross

Active Member

Reaction score: 2
Messages: 224

I have a bunch of ".serverauth.<number>" files in my home directory and receive the following error everytime I execute "startx":

Code:
xauth: file /home/niatross/.serverauth.18249 does not exist
Why are these files created in my home directory and how do I resolve the error (above)?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 6,926
Messages: 28,854

xauth(1)

It's not an error. And you probably have several of them because X didn't shutdown properly or you are using remote X.
 
OP
OP
N

Niatross

Active Member

Reaction score: 2
Messages: 224

SirDice said:
xauth(1)

It's not an error. And you probably have several of them because X didn't shutdown properly or you are using remote X.
Is there a special way that X11 should shut down? I use Fluxbox and choose "Exit". I don't see any errors and it shuts down cleanly.

Everytime I use "startx", I see the following error flash before it enters the GUI:

Code:
serverauth.18249 does not exist
Why does serverauth.18249 (or any other serverauth number) have to exist?

PS: I don't even know what "remote X" is. I use X locally (server and client) on the same machine.

How do I disable these xauth messages? I don't want to see these xauth messages anymore. I'm sick of 'em.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 6,926
Messages: 28,854

Niatross said:
Why does serverauth.18249 (or any other serverauth number) have to exist?
It doesn't. It's a file that contains a security key, which gets generated when you start X.
 

Trihexagonal

Daemon

Reaction score: 768
Messages: 1,352

Niatross said:
Is there a special way that X11 should shut down? I use Fluxbox and choose "Exit". I don't see any errors and it shuts down cleanly.
I never use the Exit option in fluxbox. I always shut down from the terminal, but that's just me:

# shutdown -r now
 

fossette

Active Member

Reaction score: 30
Messages: 120

Sorry to revive an old thread, but the problem is still current for FreeBSD 10.1. Fortunately, I did a little digging+testing and I have a solution (at least, it's good for me).

It's my understanding that the .serverauth.123 files are created during the X server startup, and they are deleted when it exits normally. My FreeBSD desktop rebooted by itself without any warning quite a few times (off-topic issue for this post) preventing the X server from exiting normally. For me, these files were created by startx, a sh script in the /usr/local/bin/ directory. startx does quite a few things, perhaps good for full blown complex system, but for a simple desktop, the default parameters for commands are usually good enough.

So, in the first few lines of the startx script, you'll see:

Code:
enable_xauth=1
I set it to 0 and the errors/warnings magically went away. :)

Dominique.
 
Top