Solved X problems in UdooX86 Ultra

I have successfully installed the following FreeBSD in my new SBC UdooX86:
1) in the internal EMMC 32GB FreeBSD 12.0
2) in the MicroSD 64GB FreeBSD 11.1 RC_2
3) in the SATA SSD disk FreeBSD 11.1 RC_2

In all installations I can't start xorg and xfce4 because I have a blank screen with a small vertical rectangle on the upper left corner and the mouse pointer

After the Xserver stop using CTRL C I have this error messagge:
failed to set mtrr Invalid argument

I upload 2 Xorg.log files of installations 1 and 2.

I have to add some informations about hardware of UdooX86:
CPU Intel® Pentium N3710 up to 2.56 Ghz (ULTRA version)
Intel® HD Graphics 405 up to 700 MHz 16 execution units (ULTRA version)
Do you know If this hardware it's supported by FreeBSD 11.1 and 12 ?

Thanks in advance
 

Attachments

  • Xorg.0.log-FreeBSD_12_amd64_UdooX86_Ultra_EMMC32GB_internal.txt
    43.5 KB · Views: 263
  • Xorg.0-UdooX86_MicroSD_FreeBSD_11.1-RC_2.log.txt
    43.5 KB · Views: 218
Braswell (Intel® HD Graphics 405) is not in the list at https://wiki.freebsd.org/Graphics. Not sure whether it's up to date though, especially for FreeBSD 12 you tried.
You can try adding this line to your /boot/loader.conf:
Code:
i915kms_load="YES"

Dear aragats

while you was writing I was adopting some instructions suggested by Benjamin user in UdooX86's mailing list here [SOLVED] Slackware64-14.2 installed and FreeBSD installed with GRUB partition identifier in progress . The firmware you suggested it's OK but need also to rebuild the kernel with GIT drm-next code. Infact, before to rebuild the kernel, I have reinstalled the 14 August 2017 version of 12.0 FreeBSD to be sure that this firmware was'nt included in this updated kernel but without a positive result. Then I have rebuilded the kernel with drm-next GIT clone and now I have a X and also xfce4 at fullHD operative without problems. It support also a second monitor on DP port (first in HDMI).

I apologize for cross posting and thank you very much for your help.
 
Back
Top