wpi very slow connection

Miko

New Member


Messages: 4

Hi i have Acer Aspire 5670 with new bios (had to change it >>ACPI-bug)
and now when wifi works (ACPI disabled)
Code:
wpi0@pci0:3:0:0:	class=0x028000 card=0x10018086 chip=0x42228086 rev=0x02 hdr=0x00
    vendor     = 'Intel Corporation'
    device     = '10418086 Intel 3945ABG Wireless LAN controller'
    class      = network
have another problem :x it connects to AP when i "sit on it"
or from outside of my house
... but connection is very slow 10-60kb (slackware ~1280)
Code:
FreeBSD  7.1-RELEASE FreeBSD 7.1-RELEASE #0: Mon Apr 13 13:19:13 IST 2009
root@vatt:/usr/src/sys/i386/compile/VATT  i386
Could you help me? Is it a bad configuration or it's "WPA"enc
Code:
# ifconfig -v wpi0 
wpi0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
	ether YY:XX:YY:XX:YY:XX
	inet 192.168.1.2 netmask 0xffffff00 broadcast 192.168.1.255
	media: IEEE 802.11 Wireless Ethernet autoselect mode 11g (OFDM/54Mbps)
	status: associated
	ssid MYAP channel 3 (2422 Mhz 11g) bssid YY:XX:YY:XX:YY:XX
	authmode WPA privacy ON deftxkey UNDEF
	TKIP 2:128-bit
	TKIP 3:128-bit powersavemode OFF powersavesleep 100 txpower 50
	txpowmax 50.0 rtsthreshold 2346 fragthreshold 2346 bmiss 7
	scanvalid 60 -bgscan bgscanintvl 300 bgscanidle 250 roam:rssi11a 7
	roam:rate11a 12 roam:rssi11b 7 roam:rate11b 1 roam:rssi11g 7
	roam:rate11g 5 -pureg protmode CTS -ht -htcompat -ampdu ampdulimit 8k
	ampdudensity - -amsdu -shortgi htprotmode RTSCTS -puren -wme -burst
	-ff -dturbo roaming MANUAL bintval 100
Code:
# rc.conf
inetd_enable="NO"
linux_enable="YES"
moused_enable="YES"
sshd_enable="YES"
ifconfig_wpi0="WPA DHCP"
Code:
# cat /etc/wpa_supplicant.conf
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
ap_scan=1
#
network={
	ssid="MYAP"
	priority=5
	proto=WPA
	psk=wpa_passphrase
}
Code:
# dmesg | grep -i wpi0
wpi0: <Intel(R) PRO/Wireless 3945ABG> mem 0xb0200000-0xb0200fff irq 17 at device 0.0 on pci3
wpi0: Ethernet address: XX:YY:XX...
wpi0: [ITHREAD]
wpi0: timeout resetting Tx ring 1
wpi0: timeout resetting Tx ring 3
wpi0: timeout resetting Tx ring 4
Thanks
 
OP
M

Miko

New Member


Messages: 4

Sorry for my last post.
Now i got an answer. If i wannt to use 'wpi' - OpenBSD is for me.
Even 'wpi' in snapshot FreeBSD 8.0 is not working correctly and under OpenBSD i enjoy wireless connection.
Cheers
 

techie

New Member

Reaction score: 3
Messages: 11

Miko said:
Now i got an answer. If i wannt to use 'wpi' - OpenBSD is for me.
Even 'wpi' in snapshot FreeBSD 8.0 is not working correctly and under OpenBSD i enjoy wireless connection.
Cheers
On http://damien.bergamini.free.fr/packages/openbsd/ you will find a couple of firmware files for ipw and other devices. The files are intended for OpenBSD but maybe they are working for FreeBSD, too.

I don't know the firmware version of wpi on FreeBSD, but if there is on Bergamini/OpenBSD on newer version, I would give it a try on FreeBSD. (conversion from binary to uuencoded ASCCI necessary)
 
OP
M

Miko

New Member


Messages: 4

Yes, it's probably firmware fault. As a newbie i just can't convert it. I was trying but no effects for me. With wpi-firmware-3.2 connnection works great under OBSD.
Thanks anyway
 

Maxamoto

Member


Messages: 39

wpi works great here

I had terrible performance with this driver as well at first. Tried a few ifconfig options after reading the man page and came up with this:

Code:
ifconfig wpi0 mode 11g mtu 1500 -powersave txpower 50 protmode cts ssid "ssid_goes_here"
Currently, I am typing this while connected to my AP from a distance of about 50 feet and through two walls. Connection speed is about 36Mbps. Hope this helps!
 
OP
M

Miko

New Member


Messages: 4

It does not help but thanks!
I am now a blissfully happy OBSD user :beergrin .
 
Top