• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Wireless network using the iwn(4) driver

bookwormep

Active Member

Thanks: 39
Messages: 117

#1
Having a recurring issue connecting to wifi while using the iwn(4) driver. At boot time, the iwn(4) driver seems to endlessly loop between Up then Down states as it tries to keep linkage. There
may be two or three lengthy cycles of this before it finally, connects (and keeps) the link. However, sometimes, no link is made after the Up, then Down repeating cycle.

I have read about using the -ht option on the ifconfig_wlan0 command. This is to disable the 'High Throughput' on, what I presume is the iwn(4) driver.

Before attempting this edit to my /etc/rc.conf file, I am asking for pros and cons of this method.
 

Snurg

Aspiring Daemon

Thanks: 250
Messages: 705

#2
Interesting... had similar experience in an university eduroam wlan with about 6-8 APs in reach.
But at home, never had that problem.
I solved that problem by starting wlan by hand when I actually needed it.
 

linux->bsd

Member

Thanks: 34
Messages: 99

#3
The diagnostics printout from wpa_supplicant() might prove useful. I used it to troubleshoot a WiFi issue similar to yours (fluctuating state, then no link). Enabling SSID broadcast on the AP fixed my issue.

/etc/wpa_supplicant.conf (wpa_supplicant.conf()):
Code:
network={
ssid="foo"
psk="bar"
}
wpa_supplicant -dKt -i wlan0 -c /etc/wpa_supplicant.conf

You'll want to disable any rc.conf configs related to wlan0, then reboot (or sh /etc/rc or /etc/netstart might work) before running wpa_supplicant.
 

bookwormep

Active Member

Thanks: 39
Messages: 117

#4
Good news, added the new edit to /etc/rc.conf:

Code:
ifconfig_wlan0="-ht WPA SYNCDHCP"
The boot looping UP and DOWN repeating cycle has ceased, linkage complete!