Solved wifi "no carrier" for intel pro wireless

so I read handbook tried all in it. installed GhostBSD. cat5 eth works fine but not wifi.

I get "iwi0: firmware stuck in state 4, resetting" message showing on the console ever how many minutes. There are a few past articles in freeBSD forum (iwi no carrier) but NONE are solved - all discuss config twiddling (which i've tried) and end up with "no carrier" at exit

ifconfig shows wlan0 is up with "status: no carrier" (as if on cat5 and cable were unplugged)

Intel PRO/Wireless 2200BG (rev 05) (dell laptop)

* /boot/loader.conf has intel license agreement set true (unsure if this works because iwi is not loaded: it's built into kernel and i have no idea if who built the kernel didn't f up and set license = no and leave no way to set it to yes)
* sysctl shows iwi is built-in
* /etc/rc.conf was already set up for wifi
* handbook 30.3 all things tried
* anything tried gets interface up but never a carrier
* dhlient cannot work "no link ..." (cable unplugged / no carrier)

wpa_supplicant.conf has ssid="foo 2" however "ifconfig wlan0 list scan" always shows only "foo 1", also, changing ssid to "foo 1" doesn't help (link) status: still no carrier. on iPhone i should see 2 for my ISP modem, and a few from neighbors too.

??? should i be using ndis driver? and can i use ndis if driver iwi is built-in to kernel / pre-loaded ? (without re-compiling kernel - noting i'm new to BSD and never made World before)

some spread rumor this means wifi card is broken it's not iwi's fault. however i just loaded windows 10 on the top before loading ghostbsd so I'm %100 that's a rumor: the wifi certainly works in win10 (however! sound doesn't in win10 but does in bsd).

also: wpa_cli (a text interface for wpa_supplicant) cannot connect to running wpa_supplicant, have no idea if this is unrelated or wpa_supplicant is breakage

thank you
Did you try to load the module manualy? Try
kldload iwi
or add
in /boot/loader.conf then reboot.
I'm sorry false alarm! Perhaps iwi is fixed.

This is how I found my mistake (where as nothing else showed me):

# ifconfig -v wlan0 list scan

With -v added I quickly saw my SSID in wpa_supplicant.conf was missing 2 characters "foo 2Ghz" "foo 2.4Ghz". I re-ran wap_supp and all was fine.

Thank you very much for your effort!

(I cannot see all hubs but now I know things are NOT broken, mark as SOLVED)