What is the correct Regdomain code?

neilms

Active Member

Reaction score: 4
Messages: 192

Hi
I am setting up FreeBSD on my laptop for use as a development machine only. I don't plan on installing any gui etc and will just use the console.
I had FreeBSD installed on this machine before but I must have not set it up correctly and want to try harder to get it right.
I will need a internet connection only to download updates and install packages from time to time.
I'm going through the installation steps now and there is a dialogue box that says select your regdomain. There is a list of codes but I'm not sure which one I should use. I live in the UK. Can anyone help me with this? Thanks.
 

ralphbsz

Daemon

Reaction score: 1,432
Messages: 2,378

This controls how your WLan client is configured: Not all countries use the same frequencies, same power, and so on. The weird things about regdomain include: (a) there is a level of indirection, in the US we say regdomain=FCC and in Europe presumable regdomain=ETSI (those are the standards/regulatory agencies that make the definitions), and (b) the country is not specified as a 2-letter code but as a full name.

For UK = GB, you probably need to set regdomain = ETSI, and country = "United Kingdom" (not UK). Don't worry too much about setting it right initially; you can always fix it later in an ifconfig command for wlan. Or ignore the wireless interface temporarily and string an Ethernet cable.
 
OP
neilms

neilms

Active Member

Reaction score: 4
Messages: 192

I'll have another go soon. I just selected a random one and the wireless didn't work at all. Thank you for your replies.
 

ShelLuser

Son of Beastie

Reaction score: 1,790
Messages: 3,600

I'd go with US. I'm using a wifi dongle in my laptop and it was manufactured somewhere in China I believe, and used within Europe yet it still uses US.

Edit: I think I'm mixing up my facts here a little bit. Right now I'm specifically referring to country code which got me a bit of trouble when I tried to set up my wifi through ifconfig.

Edit2: # ifconfig wlan0 list regdomain that might be able to give you a good clue as to what you might want to use.

And since I'm editing anyway...

For what's it worth: to get my dongle to work I also had to use a specific 3rd party firmware supplied through the Ports collection (net/bwn-firmware-kmod) before it would work at all. Obviously I can't say that this also applies to your setup, but it's something to keep in mind.

Further more: /etc/wpa_supplicant.conf. See also wpa_supplicant(8). I'm using a hidden SSID on my network and the only way I could get this to work was using this approach. A small snippet:

Code:
network={
        ssid="<my hidden SSID name>"
        scan_ssid=1
        key_mgmt=WPA-PSK
        auth_alg=OPEN
        psk=<my hidden hexadecimal password>
        priority=10
}
The reason I mention this is because I have no idea how the installation procedure handles all this. But if it doesn't support this approach then I wouldn't worry too much about your wifi not working right away because you might be able to get it working afterwards.
 

xtaz

Well-Known Member

Reaction score: 132
Messages: 455

I too live in the UK and I set this in /etc/rc.conf
Code:
create_args_wlan0="country GB"
If you look in /etc/regdomain.xml you can see that GB maps to etsi. So yes, select GB or etsi. That works fine for me.
 

Chris_H

Daemon

Reaction score: 197
Messages: 1,076

xtaz is exactly right. That is what the installer was asking for. I know this, because I just went through the whole ordeal the hard way. :p

Good luck!

--Chris
 

grahamperrin

Active Member

Reaction score: 31
Messages: 130

That page no longer exists, we have:
… select GB or etsi. …
I thnk: etsi, not GB, because the two are not synonymous for regdomain purposes.

Bearing in mind, the invitation to select a regdomain (not just a country) during installation of FreeBSD.

Code:
root@momh167-gjp4-8570p:~ # grep wlan /etc/rc.conf
create_args_wlan0="country GB regdomain etsi"
wlans_iwn0="wlan0"
ifconfig_wlan0="WPA SYNCDHCP"
root@momh167-gjp4-8570p:~ #
Code:
root@momh167-gjp4-8570p:~ # grep -A 2 GB /etc/regdomain.xml
<country id="GB">
  <isocc>826</isocc> <name>United Kingdom</name> <rd ref="etsi"/>
</country>
root@momh167-gjp4-8570p:~ #
 

xtaz

Well-Known Member

Reaction score: 132
Messages: 455

Yep. Since I wrote that post I have worked that out myself. I now use the same as you posted. "regdomain ETSI country GB".
 

Phishfry

Son of Beastie

Reaction score: 1,730
Messages: 4,806

I had a wireless module that was showing debug and had to force it. For the US:
create_args_wlan0="regdomain FCC country US"
 

cloud8111

New Member


Messages: 2

The countrycode and regdomain settings control the channels the card can operate on, as well as maximum transmission power, whether active scanning can be used, where and how ad-hoc mode can be used and also whether DFS and TPC (802.11h) support is required.
 
Top