wayfire config question

Starting wf-panel some XML config is used from the location /usr/local/share/wayfire/metadata/wf-shell.
Where do I copy those files in my home-directory to modify them ?
 
To configure the panel and the dock, wf-shell uses a config file located (by default) in ~/.config/wf-shell.ini An example configuration can be found in the file wf-shell.ini.example, alongside with comments what each option does.
 
i'm on a fresh 13.2 install following along with the handbook, and wayfire works pretty great! i can see what the OP means about xml files, though. upon starting `wayfire -c .config/wayfire/wayfire.ini` like in the handbook, the panel does not display. (nor does the dock).

opening a terminal with `<super> KEY_ENTER` like in that `wayfire.ini` file, i can run `wf-dock` to have the dock appear even though it doesn't load on startup. meanwhile,

```
$ wf-panel
II 26-08-23 08:39:12.194 - [src/file.cpp:576] Reading XML configuration options from directory /usr/local/share/wayfire/metadata/wf-shell
II 26-08-23 08:39:12.194 - [src/file.cpp:589] Reading XML configuration options from file /usr/local/share/wayfire/metadata/wf-shell/panel.xml
II 26-08-23 08:39:12.196 - [src/file.cpp:589] Reading XML configuration options from file /usr/local/share/wayfire/metadata/wf-shell/dock.xml
II 26-08-23 08:39:12.196 - [src/file.cpp:589] Reading XML configuration options from file /usr/local/share/wayfire/metadata/wf-shell/background.xml

** (wf-panel:2792): CRITICAL **: 08:39:12.223:
unhandled exception (type Glib::Error) in signal handler:
domain: g-io-error-quark
code : 1
what : Could not connect: No such file or directory
```

is the result of trying to start a panel. i see


```
# Automatically start background and panel.
# Set to false if you want to override the default clients.
autostart_wf_shell = true

# Set the wallpaper, start a panel and dock if you want one.
# https://github.com/WayfireWM/wf-shell
#
# These are started by the autostart_wf_shell option above.
#
# background = wf-background
# panel = wf-panel
# dock = wf-dock
```
in `wayfire.ini`, so i think what's going on is that the panel crashing stops the entire `wf-shell`. (the background does display).

it would be nice to have the error from Glib resolved. on the other hand, i might move on to non-GTK setups.
 
Back
Top