Video stuttering over WiFi from SMB share on FreeNAS

ionutm80

New Member


Messages: 19

Hi guys,

I have encountered a nasty problem and I do not understand which component is to blame.
I have a FreeNAS box with both SMB and NFS shares which I can access and play smoothly from them any video (even 4k rips) to several devices such as AppleTV 4k, Nvidia Shield TV, Windows PCs. Recently I have installed FreeBSD 12 Release p5 on an Lenovo Ideapad 330S-14IKB Laptop, Core I3 7100 KabyLake, Intel HD 620. I have mapped both NFS shares (mount 192.168.1.xyz:/mnt/Homeserver/Media /mnt/Media) and SMB shares via Thunar file manager (XFCE). I can see my shared folders from NAS and can play movies but it stuttering like hell from both NFS and SMB for everything higher than DVD rips meaning 1080p and 4K Blu-Ray rips. The same movies when played from an attached USB 3.0 drive are very smooth and CPU load is hoovering around 18-22% for 4k movies. I have checked and HW acceleration is enabled by libva-intel-media-driver. The laptop was tested 1m from the router and the WiFi interface used is an Intel AC 7265.
Is it a problem with either NFS and SMB over WiFi or do I have to do some fine tunning? On a side note I have played 4k trailers on Youtube with Firefox (Aquamen) and are butter smooth so the WiFi interface seems up to the task.
Are there any tests that I can perform in order to check the speed from FreeNAS shares?

Thanks a lot in advance!
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,412
Messages: 30,001

Is it a problem with either NFS and SMB over WiFi
You will need to have at least an 100Mbit connection to be able to play anything above 720p over wireless stutter-free, especially if the stream contains DD5.1 or DTS audio.

On a side note I have played 4k trailers on Youtube with Firefox (Aquamen)
I'm doubtful you actually got 4K video. It's likely scaled down to 1080p.
 
OP
OP
I

ionutm80

New Member


Messages: 19

I have also dual boot with W10 and can stream blu-ray rips stutter free from the same FreeNAS shares, same laptop. It's because W10 supports 802.11ac, no? I will try with an USB to ethernet adapter and see how it goes since I do not have a lan port on the laptop.
 

obsigna

Aspiring Daemon

Reaction score: 537
Messages: 925

Try adding socket options = TCP_NODELAY in /usr/local/etc/smb4.conf. Then restart Samba.

If this helps, you want to set it system wide by puuting the following into /etc/sysctl.conf:
Code:
net.inet.tcp.delayed_ack=0
Then restart.
 
OP
OP
I

ionutm80

New Member


Messages: 19

Try adding socket options = TCP_NODELAY in /usr/local/etc/smb4.conf. Then restart Samba.

If this helps, you want to set it system wide by puuting the following into /etc/sysctl.conf:
Code:
net.inet.tcp.delayed_ack=0
Then restart.
Thanks, I will try this and revert with feedback.
 
Top