Video: problem configuring PEFS on a home directory

Hi everyone,

I'm having a problem configuring PEFS on a user's home folder.

I made a video of me following along with a very nice tutorial on YouTube by bufo333.

Despite following all of bufo333's steps, my computer is not mounting the user's directory upon reboot. The video I made shows me copying bufo333 step-for-step. If you have time, please let me know if you see what I'm doing wrong.

Alternatively, if you have had luck setting up PEFS on a user's home folder, please share your tips and tricks.

This thread is reasonably old but, but in common with many such threads, the actual answer is never submitted. I've just set this up and discovered why Eduardo's setup doesn't work. The difference between his setup and the guy in the video is that he is using ZFS. If you are using ZFS then you need to add the "late" option into /etc/fstab because /usr/home hasn't been mounted at the point where the mounts in /etc/fstab are acted on.

So the line in /etc/fstab should be:

/usr/home/john /usr/home/john pefs rw,late 0 0

Other than that, you can follow the video and it should work. Hopefully this will help the next person.