Solved /usr/local/x86_64-portbld-freebsd13.0/

HL1234

Active Member

Reaction score: 11
Messages: 153

Short Question; I can nothing find with Google or in the forum by searching it:
For what is this directory I found in my install
/usr/local/x86_64-portbld-freebsd13.0/?
/usr/local/x86_64-portbld-freebsd13.0/lib/ldscripts etc. ?
Which program or compiler use it?
Thanks.
 

memreflect

Active Member

Reaction score: 174
Messages: 205

You would only see the /usr/local/x86_64-portbld-freebsdXX.X directory if you installed devel/binutils. As an example, some port you have installed may depend on the GNU Compiler Collection (GCC) for whatever reason, and GCC depends on GNU Binutils. To see which pkgs/ports require Binutils, you can use pkg query '%rn' binutils. You can do this for any pkg/port actually, so if it displays gcc9 for example, you can then use pkg query '%rn' gcc9 to see what you have installed that requires lang/gcc9
 
OP
HL1234

HL1234

Active Member

Reaction score: 11
Messages: 153

pkg query '%rn' binutils
--> gcc10
I have try to install lang/mono6.8 but mono conflicts with brotli.
in Makefile
Code:
CONFLICTS_BUILD=    brotli
It is recommended first to deinstall it:
pkg delete brotli
Code:
Installed packages to be REMOVED:
        ap24-mod_fastcgi: 2.4.7.1
        ap24-mod_security: 2.9.3
        apache24: 2.4.48
        brotli: 1.0.9,1
        fontconfig: 2.13.93,1
        freetype2: 2.10.4
        libXft: 2.3.3
        libgd: 2.3.1,1
        mod_php80: 8.0.6
        php80-extensions: 1.0
        php80-gd: 8.0.6
        py38-tkinter: 3.8.10_6
        tk87: 8.7.a3
Number of packages to be removed: 13
The operation will free 51 MiB.
Proceed with deinstalling packages? [y/N]: N
I need Apache and PHP. And I want mono to use with /usr/ports/www/mod_mono for Apache.
In bugs one has written:
#error: unknown type name 'BROTLI_INTERNAL'
#https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=238089
# niqck 2020-03-04
# Added USE_GCC=any to the port Makefile and now it builds on FreeBSD 12.1
So I do and it complied; Makefile
Code:
CONFLICTS_BUILD=
USE_GCC=any
but it does not install. See:
https://forums.freebsd.org/threads/...-no-such-file-or-directory.80653/#post-514560
With the solution there it goes further, but get another problem. I remembered that after upgrade to FreeBSD 13 I still has not done etcupdate. Maybe that brings the problems? But I believe ports are independent form the OS. And I had make a fresh update: portsnap fetch update
Today I try the first time etcupdate - nothing happens with it: next Tread...
 
Top