usb speakers not recognized?

fvs

Member

Thanks: 2
Messages: 41

#1
My external usb speakers wont play, My internal speakers play well but are a bit tiny.
The power from the usb connection lights the speaker.
 
Π

Π 5C15

Guest


#4
Alright...look, in FreeBSD, you can (or you must) specify which connection you will use for example, for the audio.
Here's something that probably help you: type this in a terminal and post the output.
Code:
 dmesg | grep pcm
 
OP
OP
F

fvs

Member

Thanks: 2
Messages: 41

#5
Alright...look, in FreeBSD, you can (or you must) specify which connection you will use for example, for the audio.
Here's something that probably help you: type this in a terminal and post the output.
Code:
 dmesg | grep pcm
Code:
 dmesg | grep pcm
pcm0: <Realtek ALC889A (Internal Analog 3.1/2.0)> at nid 20,22 and 24 on hdaa0
pcm1: <Realtek ALC889A (Rear Analog)> at nid 21 and 26 on hdaa0
pcm2: <Realtek ALC889A (Rear Digital)> at nid 30 and 31 on hdaa0
pcm3: <USB audio> on uaudio0
 dmesg | grep pcm
pcm0: <Realtek ALC889A (Internal Analog 3.1/2.0)> at nid 20,22 and 24 on hdaa0
pcm1: <Realtek ALC889A (Rear Analog)> at nid 21 and 26 on hdaa0
pcm2: <Realtek ALC889A (Rear Digital)> at nid 30 and 31 on hdaa0
pcm3: <USB audio> on uaudio0
 dmesg | grep pcm
pcm0: <Realtek ALC889A (Internal Analog 3.1/2.0)> at nid 20,22 and 24 on hdaa0
pcm1: <Realtek ALC889A (Rear Analog)> at nid 21 and 26 on hdaa0
pcm2: <Realtek ALC889A (Rear Digital)> at nid 30 and 31 on hdaa0
pcm3: <USB audio> on uaudio0
 
Last edited by a moderator:
Π

Π 5C15

Guest


#6
1) Connect your usb speakers.
2) Type this
Code:
 sysctl hw.snd.default_unit=3
3) Type
Code:
 mixer vol 50
4) Play some audio
5) Tell what happened
 
Π

Π 5C15

Guest


#8
6) Mark me as better answer. Nah, forget it. I don't need it. I'm glad to be helpful here.
7) Enjoy
Now you must define which output will be the default everytime that you start the system, because this is a temporal solution. When you restart you PC, you will need to type both commands again. To prevent this, do:
Code:
 ee /etc/sysctl.conf
and in the end of the file, you must put this line:
Code:
 sysctl hw.snd.default_unit=3
if you want that your OS set that output by default.
 
OP
OP
F

fvs

Member

Thanks: 2
Messages: 41

#9
6) Mark me as better answer. Nah, forget it. I don't need it. I'm glad to be helpful here.
7) Enjoy
Now you must define which output will be the default everytime that you start the system, because this is a temporal solution. When you restart you PC, you will need to type both commands again. To prevent this, do:
Code:
 ee /etc/sysctl.conf
and in the end of the file, you must put this line:
Code:
 sysctl hw.snd.default_unit=3
if you want that your OS set that output by default.
After setting sysctl hw.snd.default_unit=3 it's not working at all?
 
Last edited by a moderator:
Top