USB keyboard and mouse issue

I have my system hooked up to an iogear kvm switch for display, keyboard and mouse. Sometimes during boot and sometimes when I plug in a USB thumb drive the keyboard and mouse stop responding. Even some of the messages from system init won't show up.

If I disconnect the usb cable from the machine anything I typed while frozen will appear and so will those missing init messages. Plugging the cable back in freezes everything. Scroll lock doesn't do anything.

I've tried swapping out a different keyboard bypassing the kvm but that freezes the display as well.

If I press ctrl alt del while frozen the missing messages and typed keys will show up and the system will proceed to reboot.

I just turned off the automounter to see if the problem goes away but this may take some time to troubleshoot that way.

Was happening in 10.3 and still happening in 11.0-RC2
Would it be because this Iogear device has too much 'intelligence', and expects the reaction of a Windows computer? Ctrl-Alt-Del is so typical for Windows... Would there be a switch to turn this feature off?

I use a similar device from Belkin, and don't have these issues.

However, there are some computers that hate booting without their display+mouse+keyboard... I guess it's like not having coffee in the morning... With a MacMini, the mouse would work, but the keyboard would not let me enter the password. My work around would be to switch the screen to the other system, then back, and then the keyboard was 'unfrozen' for the MacMini.

Maybe you can try random things (plug/unplug) to see if that will address the issue. This Ctrl-Alt-Del sequence was a good start.

I tried connecting a keyboard directly to the computer after it happened and it did the exact same thing. Frozen while plugged in and displayed what was typed when unplugged.

While I suspect the iogear kvm may be triggering it, the kernel is not recovering from it.
Sometimes during boot and sometimes when I plug in a USB thumb drive the keyboard and mouse stop responding.
You may want to check the BIOS (UEFI?) for settings regarding "Legacy USB". I've found some BIOS' have settings for Legacy USB drives, this seems to interfere with the PS/2 emulation of USB keyboards/mice. Try turning any of those options on or off, can't tell which one as it requires a bit of experimenting.
I can't shut of Legacy USB Support as the boot loader won't recognize the keyboard. I have shut off Legacy USB3.0 Support and EHCI Handoff. Will see if that helps.