Solved USB Drive Writing Problem

j7j3

New Member

Reaction score: 7
Messages: 17

I am running a file and media server (11.1-RELEASE) with 2 external USB drives for storage. I upload/download to the server from my Windows 7 machine via FTP and have proftp/minidlna running on the server-side. Both the drives are NTFS with the problematic drive having 157GB/2.7TB (650GB/3.7TB on the other).

It has run like a dream up until the last week where I have been getting an input/output error uploading to one of the drives - uploading to the other drive works with no errors. I have performed a full Windows chkdsk *and* used HD Tune Pro to check for bad sectors and apart from two TV shows which ended up in the Windows version of lost+found the drive was clean.

Bizarrely I can copy the files to the drive fine in Windows but as it requires a shutdown of the server and clean disconnection of the drive every time I want to upload something it defeats the point of having a server in the first place!

Relevant part of fstab
Code:
/dev/label/EXTERNAL2    /mnt/ext2       ntfs    rw,noatime,mountprog=/usr/local/bin/ntfs-3g,gid=500,uid=500,late        0       0
/dev/label/EXTERNAL3    /mnt/ext3       ntfs    rw,noatime,mountprog=/usr/local/bin/ntfs-3g,gid=500,uid=500,late        0       0
/mnt/ext2 /usr/home/ftp/public/external2        nullfs  rw,late 0       0
/mnt/ext3 /usr/home/ftp/public/external3        nullfs  rw,late 0       0
I would ideally like to have both drives formatted with UFS but as both drives are way over 50% full it is not doable without incurring unnecessary costs re-downloading from my offsite provider. I am going to be replacing both drives with a bigger drive or two in the next 6 months (hopefully longer!) or so anyway but for now I am working to resolve this.

Is this an NTFS-3G issue I am unaware of?
 

wblock@

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 3,631
Messages: 13,850

NTFS is a proprietary, closed filesystem. NTFS-3G is a reverse-engineered filesystem driver that runs through FUSE in user mode. This is not a good combination for reliable data access.
 
OP
OP
j7j3

j7j3

New Member

Reaction score: 7
Messages: 17

Aye I know I'm aware of the limitations but it's non-essential data and all backed up so not I'm worried about the contents.
 
OP
OP
j7j3

j7j3

New Member

Reaction score: 7
Messages: 17

It was reliable enough for two years up until last week, but yes of course ;)
 

tingo

Daemon

Reaction score: 365
Messages: 1,939

One of your drives could be developing errors. Did you try running smartctl on the drives, to see if there are any errors with that?
 
OP
OP
j7j3

j7j3

New Member

Reaction score: 7
Messages: 17

There were no surface errors with either chkdsk or HD Tune Pro and Crystal Disk Info declared the drives SMART status as "Good". I thought it may be some NTFS-3G quirk I may have missed out on.... I'll declare this as solved and give myself a hard slap IRL for not formatting them as native drives in the first place. I'll get the replacement drive sooner methinks!
 
Top