Urban Terror USE_AUTH

The Linux/Mac/Windows binaries are built on a distantly forked and customised version of ioq3 here https://github.com/Barbatos/ioq3-for-UrbanTerror-4 and from what i've seen I think the auth functionality is built into this engine rather than the mod files.

FreeBSD's port is based on the separately maintained ioq3 port, so UrT acts purely as a mod without further engine customisations, although the lead 4.x dev Barbatos mentioned to me that UrT should still in theory be compatible with vanilla q3 engines... but auth is a more recent addition.

I did notice someone successfully managed to build above repo for OpenBSD with minimal changes: https://github.com/Barbatos/ioq3-for-UrbanTerror-4/pull/51/files So it may be practical to have a go on FreeBSD too.


Actually on second glance their appears to be some FreeBSD bits in that make file... although they could be historical, I did have a go at building this last year on FreeBSD with scary compile errors, but I am a C newbie.

If anyone wants to try this it might be worth looking at the ioq3 port's patch files, as a found I ended up fixing some of the same bugs done in those patch files to get it to run in 64bit on OS X so they are not necessarily platform dependent.
Forgot to mention... In case you are new to the game, auth is not actually required by many servers, actually I can't remember ever being rejected by a server for not having auth. My key broke at some point and I couldn't be bother to manually enter the massive string again.

Also without going too far OT, "{per} gunmoney" is a fun server which further modifies the game (i'm not affiliated)
So. If I understood right Urban Terror on FreeBSD is built on similar q3 engine? Without Login is not showing me the servers. Tells me that is about 360 servers but the list is empty. So I need to login first.
You might want to double check the filters in the server list. Just disable all filters to see if you can connect to anything.

Last time I tried UrT on FreeBSD earlier this year it was an outdated version... however I could still join older servers. The port has been updated recently but with minimal changes, I will see if I have the same issue when I'm next in front of my FreeBSD box.
Ok, maybe it's been broken then.

The required changes for the 4.2.023 update were minimal (mostly adding some new pk3 files), I tried doing this myself fairly successfully but abandoned it when I saw someone else updated the port.

I'm fishing out the offending commits now and they appear to be much more involved, there have also been changes to the ioQuake port that this depends on.

On another note, have you tried a binary install of this yet? (sorry I can't quickly test this stuff cos my internet connection sucks and UrT is quite big)


So there is a new maintainer of this port, and there was a whole bunch of maintainence done on all of the ioquake based ports as a group. They've all been patched together in the following commit::ac03c8c

There is a lot of fluff in that commit that is from regenerating all of the patch files (just diff headers changing) So there are less changes than there appear to be.

The urbanterror port is pretty much the same with the exception of one new file for code-qcommon-qcommon.h this just changes the master port... which appears to be correct: https://github.com/Barbatos/ioq3-for-UrbanTerror-4/blob/master/code/qcommon/qcommon.h#L254

the urbanterror-data looks about right... I will compare with mine later.
...When tries to download an external map, gives error.

Ahh, yes I remember this now. I think it's done via curl, should be fixable.

I'd like to get these issues fixed, UrT is an old favourite of mine, I will try build the latest one when I get some time and help investigate.

I'm glad you are able to play at least pure map servers in the meantime :)