updating Moodle28 to Moodle31 - php-xmlreader error

Has anyone updated from moodle28 to moodle31?

The instructions on the Moodle site are quite thorough, I was going well I thought.

I made sure the mysql engine was using InnoDB, uninstalled moodle28 using pkg, then installed moodle31

The next step is to go into administration -> site administration -> notifications and let Moodle check it's ok to update itself.

At the top of the list it said I needed to check php_extensions xmlreader. I have php56-xmlreader installed. I tried using portmaster to upgrade it to php56-xmlreader-5.6.25 but it still gave me the same error afterwards.

So if there are any Moodle admins out there who have successfully navigated this, or an update to version 29 or 30 I'd appreciate any feedback. Or a someone who understands php and can tell me why my php56-xmlreader isn't being recognised.

Looks like there isn't a security update coming out for version 28 so I figure it's time to get a little more current.

thanks in advance
andrew
 
Hi

Pez also going through the same problem now. the issue seems to be that libiconv.la is not installed or was faced out from Freebsd ( as for my system )
so am stuck at how to get the xml reader installed.

By any chance did you get a solution for your issue
 
Hi

Pez also going through the same problem now. the issue seems to be that libiconv.la is not installed or was faced out from Freebsd ( as for my system )
so am stuck at how to get the xml reader installed.

By any chance did you get a solution for your issue

hi Clintm.n

from my notes, it appears that I gave up on v3.1 at that time and used 3.0 instead.

Since then I have upgraded it numerous times with pkg by just uninstalling the installed version and installing the next version. I'm currently on 3.3. Sorry if that's not much help. I'll include my notes from the time. Please note, my FreeBSD server is a vm, and I took a snapshot first, which I needed to revert to at least once.

hope this is of some help
regards
andrew
 

Attachments

  • upgrading_moodle.txt
    28.7 KB · Views: 776
I would also second this: I updated Moodle via pkg, without any problems.

Just back up / copy, edit, etc. all data and config files as necessary, and it is good to go ;)
 
Hi

Pez also going through the same problem now. the issue seems to be that libiconv.la is not installed or was faced out from Freebsd ( as for my system )
so am stuck at how to get the xml reader installed.

By any chance did you get a solution for your issue

how did you end up going with this? did you get a working result?
 
Back
Top