Solved Updated packages gnome-shell fails with "Oh No! Something has gone wrong"

Updated my desktop with pkg and now cannot display gnome-shell. Have tried with gdm and without using startx with the same result. The installed packages that are key to my problem are:
Code:
gdm: 42.0_1
gnome-control-center: 42.0_1
gnome-settings-daemon: 42.1
gnome-shell: 41.4_2
gnome-tweaks: 40.0_2
libgweather4: 4.0.0_1
libgweather: 40.0_2
mutter: 41.4

Checking ~/.cache/gdm/sesson.log showed the following errors:

Code:
mutter-Message: 08:14:33.964: Running GNOME Shell (using mutter 41.4) as a X11 window and compositing manager

** (gnome-shell:2602): WARNING **: 08:14:35.560: ATK Bridge is disabled but a11y has already been enabled. Gjs-Message: 08:14:35.994: JS WARNING: [resource:///org/gnome/shell/ui/dateMenu.js 5]: Requiring GWeather but it has 2 versions available; use imports.gi.versions to pick one
GNOME Shell-Message: 08:14:36.057: Skipping parental controls support as it’s disabled

(gnome-shell:2602): Gjs-CRITICAL **: 08:14:37.934: JS ERROR: TypeError: method GLib.TimeZone.get_offset: At least 1 argument required, but only 0 passed_clocksChanged/<@resource:///org/gnome/shell/ui/dateMenu.js:343:46_clocksChanged@resource:///org/gnome/shell/ui/dateMenu.js:342:25
_init@resource:///org/gnome/shell/ui/dateMenu.js:309:14
_init@resource:///org/gnome/shell/ui/dateMenu.js:870:28
_ensureIndicator@resource:///org/gnome/shell/ui/panel.js:915:25
_updateBox@resource:///org/gnome/shell/ui/panel.js:926:34
_updatePanel@resource:///org/gnome/shell/ui/panel.js:871:14
_init@resource:///org/gnome/shell/ui/panel.js:681:14
_initializeUI@resource:///org/gnome/shell/ui/main.js:221:13
start@resource:///org/gnome/shell/ui/main.js:162:5
@resource:///org/gnome/shell/ui/init.js:6:17

** Message: 08:14:37.934: Execution of main.js threw exception: Module resource:///org/gnome/shell/ui/init.js threw an exception

(gnome-shell:2602): Gjs-CRITICAL **: 08:14:37.951: Attempting to call back into JSAPI during the sweeping phase of GC. This is most likely caused by not destroying a Clutter actor or Gtk+ widget with ::destroy signals connected, but can also be caused by using the destroy(), dispose(), or remove() vfuncs. Because it would crash the application, it has been blocked and the JS callback not invoked.

(gnome-shell:2602): Gjs-CRITICAL **: 08:14:37.951: The offending signal was destroy on Gjs_ui_dateMenu_DateMenuButton 0x80edb6820.
== Stack trace for context 0x807df8150 ==

Oddly there are two versions gweather installed:
Code:
libgweather4: 4.0.0_1
libgweather: 40.0_2
and they are linked as package dependencies I wonder if this is the cause of the problem, but I have no idea how to correct this.
 
pkg info -x gnome

Which version of FreeBSD, exactly? Packages from latest, or quarterly?

freebsd-version -kru ; uname -aKU

pkg -vv | grep -e url -e enabled
 
I am running with Packages from latest. Outputs from the queries requested

Code:
pkg info -x gnome
gnome-autoar-0.4.1
gnome-color-manager-3.36.0_1
gnome-control-center-42.0_1
gnome-desktop-42.0
gnome-icon-theme-3.12.0_1
gnome-icon-theme-symbolic-3.12.0
gnome-keyring-40.0_1
gnome-online-accounts-3.40.1_1
gnome-session-42.0
gnome-settings-daemon-42.1
gnome-shell-41.4_2
gnome-tweaks-40.0_2
gnome_subr-1.0
libgnome-keyring-3.12.0_2
libgnomekbd-3.26.1
pinentry-gnome3-1.2.0
polkit-gnome-0.105_1

Code:
freebsd-version -kru ; uname -aKU
13.0-RELEASE-p8
13.0-RELEASE-p8
13.0-RELEASE-p10
FreeBSD Ruru 13.0-RELEASE-p8 FreeBSD 13.0-RELEASE-p8 #0: Tue Mar 15 09:36:28 UTC 2022     root@amd64-builder.daemonology.net:/usr/obj/usr/src/amd64.amd64/sys/GENERIC  amd64 1300139 1300139

Code:
pkg -vv | grep -e url -e enabled
    url             : "pkg+http://pkg.FreeBSD.org/FreeBSD:13:amd64/latest",
    enabled         : yes,
 
I'm seeing the same thing after a poudriere build on my local machine. I had just switched back to 'latest', I guess now I will try 2022Q2. It takes all night to rebuild when things like libxml2 change, and then in the morning, I might have to rebuild 900 ports again.

Writing this from Ubuntu.
 
hello !
This worked for me. It may be a bug!
Log into a console with your username.

You can backup your Gnome Desktop settings with:
dbus-launch dconf dump / > gnome-desktop.dconf

You can reset all clocks settings with:
dbus-launch dconf reset -f /org/gnome/clocks/
dbus-launch dconf reset -f /org/gnome/shell/world-clocks/
You can now try to log into Gnome Desktop.

If you want to restore your backup:
dbus-launch dconf reset -f /
dbus-launch dconf load / < gnome-desktop.dconf
 
I can confirm this restores my gnome desktop! Although, in my case, I hadn't had my second coffee and did the 'dbus-launch dconf reset -f /' so now everything is reset.

You should mention that you run the the dbus-launch commands as your user above, I think, right?
 
hello !
This worked for me. It may be a bug!
Log into a console with your username.

You can backup your Gnome Desktop settings with:
dbus-launch dconf dump / > gnome-desktop.dconf

You can reset all clocks settings with:
dbus-launch dconf reset -f /org/gnome/clocks/
dbus-launch dconf reset -f /org/gnome/shell/world-clocks/
You can now try to log into Gnome Desktop.

If you want to restore your backup:
dbus-launch dconf reset -f /
dbus-launch dconf load / < gnome-desktop.dconf
Thank-you. Not sure how it achieved it but this solved my problem gnome is up and running again.
 
Top