Solved Unable to obtain stable/13 sources with gitup

ssw01

Member

Reaction score: 3
Messages: 34

I'm interested in testing Bjoern Zeeb's iwlwifi work on my laptop running 13.0-RELEASE-p3 and to that end
I need the stable/13 kernel sources.

With a completely empty /usr/src, I ran gitup stable, after editing gitup.conf appropriately.
The result was

Code:
# Scanning local repository...
# Host: git.freebsd.org
# Port: 443
# Repository Path: /src.git
# Target Directory: /usr/src
# Want: 8e24b25b67bb664168e3daf41d7b2262f5b136d5
# Branch: stable/13
# Action: clone
gitup: load_object: local file for object 3331601f6dc50ef2c9779c1656218701b48b276c -- /usr/src/sys/contrib/openzfs/scripts/zfs-images not found: No such file or directory

Is this a temporary thing or am I doing something that's expected to not work?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,055
Messages: 38,512

Is this a temporary thing or am I doing something that's expected to not work?
It should work. There's still development going on with the tool, so you might be hitting a bug. Make sure you're using the latest version of net/gitup, and try again. See if you can reproduce the error, that'll make it easier to find (and fix) the bug.
 

jb_fvwm2

Daemon

Reaction score: 205
Messages: 1,829

I ran into that exact same error, don't remember how it was resolved. [ I might have switched to git, can't be sure because I have more than one install and don't remember the details for each one.
 
OP
S

ssw01

Member

Reaction score: 3
Messages: 34

I'm running version 0.94. Version 0.95 dropped 3 days ago and the diiffs appear to be entirely
unrelated. This is completely repeatable for me.

In the interests of completeness, I'll build 0.95 when I get a chance and try again. If it fails, I'll submit a report.

Thanks!
 
OP
S

ssw01

Member

Reaction score: 3
Messages: 34

Just to close the loop on this, after updating gitup to 0.95, gitup stable worked.
Whether this was due to the changes in the tool or in the repo, I can't say but it's all good now.

Thanks!
 
Top