Solved Unable to launch Lumina on fresh FreeBSD 11

Afternoon all,

I've got a Lenovo T440 that was running FreeBSD-CURRENT over the past year or so. While I mostly ran Xfce on it when Lumina 1.0 was ready I gave it a spin for a couple of days before heading back to Xfce.

When FreeBSD 11 was released I decided to reinstall the laptop, do UEFI boot, encrypted boot/swap, etc. So I've got a fresh install. I've installed Lumina via pkg(8), installed and started dbus (suggested in Thread 56195). When I try to start Lumina, I get:
Code:
QCoreApplication::applicationFilePath: Please instantiate the QApplication object first


X.Org X Server 1.17.4
Release Date: 2015-10-28
X Protocol Version 11, Revision 0
Build Operating System: FreeBSD 11.0-RELEASE-p1 amd64 
Current Operating System: FreeBSD bil-bsd 11.0-RELEASE-p1 FreeBSD 11.0-RELEASE-p1 #0 r306420: Thu Sep 29 01:43:23 UTC 2016     root@releng2.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC amd64
Build Date: 09 October 2016  01:54:35AM

Current version of pixman: 0.34.0
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Oct 20 12:24:52 2016
(==) Using default built-in configuration (30 lines)
xterm: No absolute path found for shell: 
xinit: connection to X server lost


waiting for X server to shut down .(II) Server terminated successfully (0). Closing log file.

I'm not sure why this isn't working...I've installed the Xfce packages and that works fine, but I'd like to give Lumina another go.

Loaded kernel modules:
Code:
Id Refs Address            Size     Name
 1   77 0xffffffff80200000 1fa7c38  kernel
 2    1 0xffffffff821a9000 30aec0   zfs.ko
 3    2 0xffffffff824b4000 adc0     opensolaris.ko
 4    1 0xffffffff824bf000 21bd0    geom_eli.ko
 5    1 0xffffffff824e2000 b3e8     aesni.ko
 6    1 0xffffffff824ee000 100ae8   i915kms.ko
 7    2 0xffffffff825ef000 55b0     iicbb.ko
 8    5 0xffffffff825f5000 6ec0     iicbus.ko
 9    2 0xffffffff825fc000 4480     iic.ko
10    2 0xffffffff82601000 881c0    drm2.ko
12    2 0xffffffff8269c000 2a270    drm.ko
13    1 0xffffffff826c7000 27670    if_iwm.ko
14    1 0xffffffff826ef000 1016a0   iwm7260fw.ko
15    1 0xffffffff82b3d000 4fac     ng_ubt.ko
16    5 0xffffffff82b42000 befc     netgraph.ko
17    1 0xffffffff82b4e000 a58f     ng_hci.ko
18    3 0xffffffff82b59000 107c     ng_bluetooth.ko
19    1 0xffffffff82b5b000 d57d     ng_l2cap.ko
20    1 0xffffffff82b69000 1b187    ng_btsocket.ko
21    1 0xffffffff82b85000 393d     ng_socket.ko
22    1 0xffffffff82b89000 3de40    linux.ko
23    2 0xffffffff82bc7000 7b08     linux_common.ko
24    1 0xffffffff82bcf000 389f4    linux64.ko
25    1 0xffffffff82c08000 c1d7     i915.ko

loader.conf
Code:
geli_ada0p5_keyfile0_load="YES"
geli_ada0p5_keyfile0_type="ada0p5:geli_keyfile0"
geli_ada0p5_keyfile0_name="/boot/encryption.key"
aesni_load="YES"
geom_eli_load="YES"
vfs.root.mountfrom="zfs:zroot/ROOT/default"
kern.geom.label.disk_ident.enable="0"
kern.geom.label.gptid.enable="0"
zpool_cache_load="YES"
zpool_cache_type="/boot/zfs/zpool.cache"
zpool_cache_name="/boot/zfs/zpool.cache"
geom_eli_passphrase_prompt="YES"
zfs_load="YES"
i915kms_load="YES"
# WIFI
if_iwm_load="YES"
iwm7260fw_load="YES"
legal.intel_iwm.license_ack="YES"
# Boot logo
loader_logo="beastie"

rc.conf
Code:
Xorgclear_tmp_enable="YES"
syslogd_flags="-ss"
sendmail_enable="NONE"

hostname="bil-bsd"
keymap="uk"
dumpdev="AUTO"
zfs_enable="YES"

wlans_iwm0="wlan0"
ifconfig_wlan0="WPA DHCP"
ifconfig_em0="DHCP"
create_args_wlan0="country GB"

local_unbound_enable="YES"
sshd_enable="YES"
ntpd_enable="YES"
powerd_enable="YES"
powerd_flags="-a adaptive -b adaptive -n adaptive"
performance_cx_lowest="C3"
economy_cx_lowest="C3"
#hald_enable="YES"
dbus_enable="YES"
avahi_daemon_enable="YES"
avahi_dnsconfd_enable="YES"
linux_enable="YES"

Xorg.0.log and dmesg attached.

Anyone know what I can do to troubleshoot/solve this?
 

Attachments

  • dmesg.txt
    43.1 KB · Views: 423
  • Xorg.0.log.txt
    17.8 KB · Views: 366
I know the point is 11-RELEASE... but, in case it help someway:

I had a strange crash after start lumina. I had no ideia of the cause, but I found a workaround.

Just after the last splash screen says lumina was loaded, it crashes. I soon discovered that if my ethernet was down, then I could launch the desktop. Then I realized that the default desktop plugin named RSS Feeds had something to do, it crashed after sync on internet. I remove it. And no more crashes now.

I'm running 10.2-RELEASE 32 bit. the problem happened with lumina 1.0 from ports, and with other commits after that.
 
I know the point is 11-RELEASE... but, in case it help someway:

I had a strange crash after start lumina. I had no ideia of the cause, but I found a workaround.

Just after the last splash screen says lumina was loaded, it crashes. I soon discovered that if my ethernet was down, then I could launch the desktop.

Unfortunately, this doesn't seem to get resolved by downing my Ethernet or/and WiFi...
 
forquare , I'm sorry it did not worked.

What about TrueOS forums? A second choice is the author's github issues. Since they follow us, maybe they can help you. If so, share the solution with us later :D

Cheers.
 
Turns out that Lumina 1.1.0 solves the issue. No idea what caused it, I'm afraid, but I did and update and everything now works.
 
Turns out that Lumina 1.1.0 solves the issue. No idea what caused it, I'm afraid, but I did and update and everything now works.

I am also having the same problem.
I have installed Lumina with
pkg install lumina

And version is installed this way.
If version 1.1, fixes the issue then, how to install Lumina 1.1 ? because pkg install lumina installs version 1
 
I am also having the same problem.
I have installed Lumina with
pkg install lumina

And version is installed this way.
If version 1.1, fixes the issue then, how to install Lumina 1.1 ? because pkg install lumina installs version 1

Are you using the quarterly or latest pkg repo? I'm using latest and was able to update to Lumina 1.1 using that.
 
Are you using the quarterly or latest pkg repo? I'm using latest and was able to update to Lumina 1.1 using that.

Solved.
I was actually executing start-lumina-desktop from FreeBSD Shell.
and I was getting this error:

QCoreApplication::applicationFilePath: Please instantiate the QApplication object first

It was probably because, X was not started yet.

I then, created the .xinitrc file, and executed startx. Lumina started successfully in this case.
 
Just a note that the newer version of start-lumina-desktop will now automatically start an X11 session for you as needed.
 
I had been struggling to get xfce4 working on FreeBSD 11 ( I did have it working on 10.3...) but after reading this thread I thought I'd try Lumina, and that installed with no problem, so I guess I'll stick with it.
 
Unfortunately, I can't get either Xfce or Lumina working under 11.0-RELEASE on a ThinkPad X220.

What do you put in .xinitrc?

I have the latest version of Lumina.
 
Back
Top