• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Trying to install FreeBSD on VirtualBox

mrmylanman

New Member

Thanks: 8
Messages: 4

#1
Hey all,

I am extremely new to BSD but I am trying to tiptoe into it, since I am a little bored with Linux, I figured it might be something semi-interesting to check out.

I tried to boot it up using the default option, and it just hangs almost immediately (roughly 1 second). Here is the output I can see:
Code:
frame pointer          = 0x28:0xffffffff811a5bf0
code segment           = base 0x0, limit 0xfffff, type 0x1b
                       = DPL 0, pres 1, long 1, def32 0, gran 1
processor eflags       = interrupt enabled, resume, IOPL = 0
current process        = 0 (swapper)
trap number            = 12
panic: page fault
cupid = 0
KDB: stack backtrace:
#0 0xffffffff805f4e0e at kdb_backtrace+0x5e
#1 0xffffffff805c2d07 at panic+0x187
#2 0xffffffff808ac600 at trap_fatal+0x290
#3 0xffffffff808ac9df at trap_pfault+0x28f
#4 0xffffffff808acebf at trap+0x3df
#5 0xffffffff80894fb4 at calltrap+0x8
#6 0xffffffff8088f04f at nexus_acpi_attach+0x7f
#7 0xffffffff805eea09 at device_attach+0x69
#8 0xffffffff805f0316 at bus_generic_new_pass+0xd6
#9 0xffffffff805f002a at bus_set_pass+0x7a
#10 0xffffffff80891c3a at configure+0x77
#11 0xffffffff8057c097 at mi_startup+0x77
#12 0xffffffff8018e09c at btext+0x2c
uptime: 1s
Automatic reboot in 15 seconds - press a key on the console to abort
I don't think I can scroll up, because when I press a key to abort, the next key I press makes it reboot I think, so sorry if not enough information is shown. I tried single user and the same behavior is exhibited. When I try to boot into safe mode, rather than pulling up the panic dialog, it just freezes as shown below:
Code:
pci0: <base peripheral> at device 4.0 (no driver attached)
pci0: <multimedia, audio> at device 5.0 (no driver attached)
ohci0: <OHCI (generic) USB controller> mem 0xf0804000-0xf0804fff irq 11 at device 6.0 on pci0
ohci0: Could not allocate irq
device_attach: ohci0 attach returned 6
pci0: <bridge> at device 7.0 (no driver attached)
ehci0: <Intel 82801FB (ICH6) USB 2.0 controller> mem 0xf0805000-0xf0805fff irq 10 at device 11.0 on pci0
ehci0: Could not allocate irq
device_attach: ehci0 attach returned 6
cpu0 on motherboard
orm0: <ISA Option ROMs> at iomem 0xc0000-0xc8fff,0xe2000,0xe2fff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atrtc0: <AT Real Time Clock> at port 0x70 irq 8 on isa0
atrtc0: Warning: Couldn't map Interrupt.
fdc0: cannot reserve interrupt line
ppc0: cannot reserve I/O port range
Timecounter "TSC" frequency 2763283440 Hz quality 800
Timecounters tick every 10.000 msec
md0: Preloaded image </boot/mfsroot> 4194304 bytes at 0xffffffff80d9fe20
I'm still trying to figure out where to start with this, since I can't even get it to boot, haha. I'd greatly appreciate any help or a point in the right direction. Thanks!
 

wblock@

Administrator
Staff member
Administrator
Moderator
Developer

Thanks: 3,607
Messages: 13,850

#2
What version of VirtualBox? What is the configuration of the VM?
 

Azarien

New Member

Thanks: 1
Messages: 9

#3
It works for me with default settings. I'm using FreeBSD 8.2 32-bit guest, Windows 7 32-bit host, VirtualBox 4.0.10 r72479.

here is my current config.

virtual machine settings:
operating system - BSD
version - FreeBSD
base memory - 768 MB

Code:
chipset - PIIX3
[ ] enable io apic
[ ] enable efi
[ ] hardware clock in utc
[ ] enable absolute pointing device
processors: 1 CPU (when i set more than one core i get rare random guest reboots)
[ ] enable pae/nx
[v] enable vtx/amdv
[ ] enable nested paging

display: 24 MB
monitor count: 1
[v] enable 3D acceleration
[ ] enable 2D video acceleration

storage: type PIIX4
[v] use host io cache
hard disk: IDE Primary Master, 20 GB (be generous, it won't allocate all space until needed)

audio: intel HD audio
network: bridged or NAT as needed
[ ] enable serial port (I didn't test it)
[ ] enable usb controller (virtualbox crashes when I try to mount a device)
shared folders: not tested, I'm using ftpd on guest to share files.
now for the guest system:

/boot/loader.conf settings
Code:
   kern.hz=100
   snd_hda_load="YES"
/etc/rc.conf settings
Code:
   # this requires "emulators/virtualbox-ose-additions" port installed
   vboxguest_enable="YES"
   vboxservice_enable="YES"
/etc/X11/xorg.conf settings
- in section "InputDevice" change Driver to "vboxmouse"
- in section "Device" change Driver to "vboxvideo"
[cmd=]cp /usr/local/share/hal/fdi/policy/10osvendor/90-vboxguest.fdi /usr/local/etc/hal/fdi/policy/[/cmd]
or else it may fail to initialize the mouse driver.

/etc/sysctl.conf settings
Code:
# fix for HDA sound playing too fast/too slow. only if needed.
dev.pcm.0.play.vchanrate=44100
dev.pcm.1.play.vchanrate=44100
dev.pcm.2.play.vchanrate=44100
dev.pcm.0.rec.vchanrate=44100
dev.pcm.1.rec.vchanrate=44100
dev.pcm.2.rec.vchanrate=44100
 

mrmylanman

New Member

Thanks: 8
Messages: 4

#4
Sorry guys, I think I solved the issue. It seems like it doesn't like the PIIX3 in my case for whatever reason. I changed the chipset in System to ICH6 and in Storage to ICH9 and it seems to be working now!

I just realized this morning when I was about to reboot that although I didn't select ICH6, it still referenced it in the output... and on a hunch tried switching to it, and it worked! Case closed (for now).
 

adamreiswig

New Member


Messages: 1

#5
I had the same issue. I was attempting to install FreeBSD 64bit into a 32bit session of VirtualBox. Deleting and recreating a 64bit session resolved the issue.
 

Disturbo

New Member


Messages: 11

#6
Right click on your FreeBSD entry in Virtualbox.
Choose "Settings."
Select "System."
Under "Extended Features:" check the "Enable IO APIC" checkbox.

Then start the VM.
 
Top