Trying to burn img to usb drive

I tried this on a couple USB drives and it won't boot up from that USB. I did try another bootable USB and that one works (Ubuntu install bootable USB), so that's proof its looking at the USB drive first to try to boot from it. The USB device seems to be good: It can be formatted and files placed on it.

I tried the dd command both with and without The 'conv=sync' clause (command & output further down)

From instructions:

Log below, which includes finding the device name (sdb) with a dmesg command, as seen in another forum.
sudo dmesg | tail -20
[ 6120.075295] sdb:
[ 6120.277681] sdb:
[ 6125.450735] usb 2-1.1: USB disconnect, device number 38
[ 6129.334746] usb 2-1.1: new high-speed USB device number 39 using ehci-pci
[ 6129.627741] usb 2-1.1: New USB device found, idVendor=13fe, idProduct=5500
[ 6129.627751] usb 2-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 6129.627757] usb 2-1.1: Product: USB DISK 3.0
[ 6129.627761] usb 2-1.1: Manufacturer:
[ 6129.627765] usb 2-1.1: SerialNumber: 070D52AE9C479143
[ 6129.628517] usb-storage 2-1.1:1.0: USB Mass Storage device detected
[ 6129.630928] scsi host12: usb-storage 2-1.1:1.0
[ 6130.719709] scsi 12:0:0:0: Direct-Access USB DISK 3.0 PMAP PQ: 0 ANSI: 6
[ 6130.721013] sd 12:0:0:0: Attached scsi generic sg2 type 0
[ 6131.898745] sd 12:0:0:0: [sdb] 30283008 512-byte logical blocks: (15.5 GB/14.4 GiB)
[ 6131.899472] sd 12:0:0:0: [sdb] Write Protect is off
[ 6131.899480] sd 12:0:0:0: [sdb] Mode Sense: 23 00 00 00
[ 6131.900194] sd 12:0:0:0: [sdb] No Caching mode page found
[ 6131.900201] sd 12:0:0:0: [sdb] Assuming drive cache: write through
[ 6131.935745] sdb:
[ 6131.939076] sd 12:0:0:0: [sdb] Attached SCSI removable disk
x1@aaa:~/Desktop$ sudo umount /dev/sdb
umount: /dev/sdb: not mounted
x1@aaa:~/Desktop$ sudo dd if=FreeBSD-11.0-RELEASE-amd64-memstick.img of=/dev/sdb bs=1M
dd: failed to open 'FreeBSD-11.0-RELEASE-amd64-memstick.img': No such file or directory
x1@aaa:~/Desktop$ sudo dd if=FreeBSD-11.0-RELEASE-amd64-memstick.img of=/dev/sdb bs=1M
700+1 records in
700+1 records out
734077952 bytes (734 MB, 700 MiB) copied, 101.367 s, 7.2 MB/s
If anyone has any ideas, please let me know. I don't see many requests in these forums for help in the img issue leading me to believe it's me doing something wrong; I just can't figure what.
Thanks, ASX, for looking at it. Yes, the hash is good. I do have another computer which I can use to burn a CD from the ISO, so I'll probably end up doing that some time in the future. I'm sticking with Ubuntu for now, and I have to focus on a job search instead of a new OS.