Trouble starting xorg with AMD gpu

maxm

New Member


Messages: 2

Hi,

I'm struggling to set up xorg on freeBSD release 13.0.
After installing xorg and the xf86-video-amdgpu driver and adding myself to the video group, if I run the startx command I am asked to specify BusIDs and that I cannot be in framebuffer mode.
I've tried reinstalling the system 4 or 5 times.

Also worth noting, When using freeBSD the menu contains an actual image rather than the ASCII art, I could only find a few examples of this on the internet and none of them mentioned why (This happens on both the installer and the menu). I don't know if the cause for the image is the same as the cause for the xorg problem.

Thanks, Max.

EDIT: Sorry for not mentioning, I'm using an AMD Radeon RX 5700 XT (50th Anniversary Edition)
 

bobmc

Member

Reaction score: 35
Messages: 81

Try dmsg | grep AMD . That should show your Radeon being detected by the firmware in /boot/modules . I am not sure what steps should be done next for your device.
 

Tieks

Active Member

Reaction score: 66
Messages: 158

bobmc said:
Try dmsg | grep AMD

Typo, try dmesg | grep AMD instead. The next step may be to look at the contents /var/log/Xorg.0.log after running startx, that will show what's going wrong.
It has nothing to do with that image on the FreeBSD boot menu.
 

Alain De Vos

Daemon

Reaction score: 548
Messages: 1,893

To know the pci-id of your device,
Code:
pciconf -lv | egrep -i "radeon|amd|class="
To see which modules are loaded by X,
Code:
cat /var/log/Xorg.0.log | grep -i module
 
Top