Thunderbird 52.2 cannot see local mail dir

I've just upgraded thunderbird to 52.2 and when I run it it tells me my local mail folder (~/.thunderbird/...) is invalid. But the path it gives as being invalid is the one with the locally stored mail; the one it created some time ago. If I choose to browse for it the browse pane doesn't even show dot files. (Sheesh.)

Perhaps a clue is that thunderbird opens and tells me the calendar extension is not there. That's good because I unchecked it in make config. Anyone here know what thunderbird thinks is going on?

Edit: I did an svn update and make distclean and am re-compiling now.

Answering my own post to say I managed to move around the problem by renaming .thunderbird, uninstalling thunderbird, re-installing thunderbird, and creating a new user. I then moved my local mail ("Mail") folder into the new bar.default directory. It worked and all the mail appears to be there. I did manage to trigger the "invalid path" a couple times but I'm not interested in testing why that actually happens. It's as if thunderbird was pointed at the old foo.default directory one time too many and marked it as being suspect. Or something. Just crappy software I suppose, although it's fine until it decides to go crazy. Definitely not solved. I'll add that as I was untarring things I did see mention of a directory called "telemetry". Might want to look into that.