Other Three Questions About File Systems

Here is my /etc/fstab file:
/dev/ada0s5a                       /                   ufs       rw               1 1
/dev/ada0s5b                       none                swap      sw               0 0
/dev/ada1s8l                       /NetBSD             ufs       ro               0 0
proc                               /proc               procfs    rw               0 0
fdescfs                            /dev/fd             fdescfs   rw               0 0
linproc                            /compat/linux/proc  linprocfs rw               0 0
linsys                             /compat/linux/sys   linsysfs  rw               0 0
/dev/da0s1                         /mnt/vfat           msdosfs   rw,-m=777,noauto 0 0
/dev/linux_lvm/m5-scientific_linux /ScientificLinux    ext2fs    ro,failok        0 0
/dev/linux_lvm/m5-SLES_mimage_0    /SuSE               ext2fs    ro,failok        0 0
/dev/linux_lvm/m5-ubuntu_mimage_0  /Ubuntu             ext2fs    ro,failok        0 0
/dev/linux_lvm/m5-rhel_mimage_0    /RHEL7              ext2fs    ro,failok        0 0
/dev/ada1s1                        /Windows7           ntfs-3g   late,mountprog=/sbin/mount_ntfs-3g,failok 0 0

As you can see, my computer is a multiboot machine, and I have several different operating systems sharing the same hardware. One of them is Windows 7, and I want to be able to access its files when I am running FreeBSD. FreeBSD once had native ntfs support, just as it once had native xfs support, but it no longer does, so I must install sysutils/fusefs-ntfs, which I have done, and I must say fuse_load=YES in /boot/loader.conf, which I have done. I now have /usr/local/bin/ntfs-3g (to which I have symbolically linked /sbin/mount_ntfs-3g) and I have no problem accessing my Windows 7 system after invoking the command
ntfs-3g /dev/ada1s1 /Windows7
. I could put that command in /etc/rc.local and be done with it, but it is better to put your mounts in /etc/fstab, which is what I am trying to do. But I cannot get it to work. Line 13 of /etc/fstab, which you see above, is the last version of a long series of attempts that have all failed. The mountprog= option is unnecessary and redundant, since /sbin/mount_ntfs-3g is the default mount program, but I was grasping at straws. It made no difference, all of my attempts have produced the error message
fstab: /etc/fstab:13: Inappropriate file type or format
. What must I put in /etc/fstab to cause an ntfs filesystem to be automatically mounted at boot?

Unrelated to the above, I also have NetBSD 7.0 and OpenBSD 5.7 sharing my hardware, and although both of them have been a disappointment (because ZFS support in OpenBSD is nonexistent, and ZFS support in NetBSD is worse than nonexistent, it actually causes your files to be truncated to zero length whenever you write to them, which I cannot understand, because ZFS was open-sourced in OpenSolaris, and NetBSD could at least bring its ZFS support up to the point that FreeBSD supports it, but I digress), I installed them on my computer and I would like to be able to access those systems when FreeBSD is running. I am able to access the NetBSD filesystem with a
mount -t ufs -o ro /dev/ada1s8l                       /NetBSD
(I might even be able to get it to work without the "-o ro", but I don't want to hazard that). But I cannot access the OpenBSD filesystem with a "mount -t ufs", the mount fails. Is there a mount option that will enable me to access my OpenBSD filesystem (similar to the "-o ufstype=" option in Linux), or has the OpenBSD version of ufs deviated from the FreeBSD version beyond the point where FreeBSD can access an OpenBSD filesystem?

Unrelated to the above, I have 4 Linux systems sharing my hardware. In all 4 cases the root filesystem is ext2fs (because I wanted FreeBSD to be able to access them); in all 4 cases the root filesystem is on a logical volume, and in 3 of those 4 cases, the logical volume is mirrored across my 2 disks. FreeBSD does not see the mirrored devices:
# ls -l /dev/linux_lvm 
total 0
crw-r-----  1 root  operator  0x99 Jan 13 11:50 m5-SLES_mimage_0
crw-r-----  1 root  operator  0xb5 Jan 13 11:50 m5-SLES_mimage_1
crw-r-----  1 root  operator  0xb6 Jan 13 11:50 m5-SLES_mlog
crw-r-----  1 root  operator  0x9b Jan 13 11:50 m5-rhel_mimage_0
crw-r-----  1 root  operator  0xb9 Jan 13 11:50 m5-rhel_mimage_1
crw-r-----  1 root  operator  0x9c Jan 13 11:50 m5-rhel_mlog
crw-r-----  1 root  operator  0x9d Jan 13 11:50 m5-scientific_linux
crw-r-----  1 root  operator  0x9e Jan 13 11:50 m5-swapa
crw-r-----  1 root  operator  0xbc Jan 13 11:50 m5-swapb
crw-r-----  1 root  operator  0x9a Jan 13 11:50 m5-ubuntu_mimage_0
crw-r-----  1 root  operator  0xb7 Jan 13 11:50 m5-ubuntu_mimage_1
crw-r-----  1 root  operator  0xb8 Jan 13 11:50 m5-ubuntu_mlog
Is there anything I can do with GEOM_LINUX_LVM that will enable FreeBSD to see the mirrored devices? Currently, as you can see from my /etc/fstab, I am selecting one of the mirrored images and mounting that readonly, but that is not a satisfactory solution.

Thank you in advance for any and all replies.
The first of the 3 problems has been solved. In FreeBSD, the 4th field of /etc/fstab must explicitly contain either ro or rw (or sw or xx), there is no notion of a default value for that option in the /etc/fstab file even though when you mount by hand you do not need to specify it. I added rw to the comma-separated list of options, and it now works -- although, interestingly, it fails when I remove mountprog=/sbin/mount_ntfs-3g, even though that is supposed to be the default value for -t ntfs-3g. Well, I should say, more precisely, that a "mount /Windows7" works, I haven't yet rebooted to test whether it will mount automatically upon reboot, but I expect that it will.

As for the remaining 2 questions (OpenBSD ufs and LVM mirrors), they remain unanswered, and I thank you in advance for any and all replies.