There is an estimate date to relase new PEAR?

wisdown

Active Member

Reaction score: 13
Messages: 131

Hey guys,

Finishing the updates on my box, the remaining application with problem seems be the outdate:

devel/pear/

FreeBSD still on 1.10.1 and as stable already exists the version 1.10.3

http://pear.php.net/package/PEAR/download/1.10.3

The notes on version 1.10.0 says have support to PHP 7, but the FreeBSD version 1.10.1 only look for PHP 5.6, with dependencies:

Code:
php56-xml: 5.6.30
libevent2: 2.0.22_1
php56: 5.6.30
php56-zlib: 5.6.30

Since PHP7 become the default day after the day, is not the time for change it? Or at least let support for both?

Notes on 1.10.0:

http://pear.php.net/package/PEAR/download/1.10.0

My Box have only PHP 7.0 inside.

Note: If I remember right there another problem, the lievent2 on last updates was not named back to libevent? If is right will fail too.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 13,046
Messages: 39,678

Since PHP7 become the default day after the day, is not the time for change it? Or at least let support for both?
There is support for both. There's even support for PHP 7.1 now. But you're going to have to build from ports to be able to deviate from the default. The official packages are based on the defaults and the default is 5.6. You can't change this after the packages have been built.

Add to /etc/make.conf:
Code:
DEFAULT_VERSIONS+= php=7.0
Then build PEAR. It should now depend on PHP 7.0 instead of 5.6.

As for getting PEAR updated, ask the maintainer, politely, if he's already working on it.
 
OP
W

wisdown

Active Member

Reaction score: 13
Messages: 131

Add to /etc/make.conf:
Code:
DEFAULT_VERSIONS+= php=7.0
Then build PEAR. It should now depend on PHP 7.0 instead of 5.6.

Mine already have that, currently have this values:

Code:
DEFAULT_VERSIONS+= mysql=10.1m  ssl=openssl php=7.0

When I try compiling it from ports got segment fault at start everytime, and have no luck looking for error logs.
 
OP
W

wisdown

Active Member

Reaction score: 13
Messages: 131

As for getting PEAR updated, ask the maintainer, politely, if he's already working on it.

I have contacted him, and an new version will come soon.

Seems the support is only for php5.6 like I have sayed before, note:

Currently, PHP56 is the default version in FreeBSD.
There is a new version for devel / pear. This should I have finished in about 2 weeks to commit. Then php70 and php71 should work.
 
Top