ZFS System crashes if mfid disk fails

I tried to simulate failure one of disks:
# mfiutil fail 5
System crashes.
Each disk in raid0 mode.
zfs raidz2 build from bunch of mfids
This happens only under heavy load

Kernel Panic, and after several seconds system reboots.
I know that this is not recommended, but controller does not sopport JBOD mode.

I've tried to do same thing in idle mode and it was ok.
Anyway system should not behave this way.
Again, info about the panic would be helpful. My hunch is you have a zfs-deadman panic. This will occur when zfs finds it cannot flush buffers in a reasonable amount of time (ca 10 seconds); and instead of making matters worse by letting buffers fill even further zfs "pulls the emergency handle". Your indications (high load and hardware raid taking its time to reorganize at bios speed) point in that direction.
I have seen some cases where switching to the newer mrsas(4) driver resolved instabillity. This post http://lists.dragonflybsd.org/pipermail/users/2014-July/128703.html and mfi(4) can help you moving to mrsas. Your card needs to be supported, but the hw-list in both mrsas and mfi manpages is not complete; ie both drivers will work with more cards then shown in the list.
Also, your card might not support real JBOD (seen that on Dell Perc's) but the next best thing is defining a single volume for every disk (unmirrored). This will also prevent the hw-raid card from going into trickle-mode when a disk fails.