Solved svnlite misconfiguration? can not make buildkernel...

I'd like to build a kernel to remove the sound drivers and try oss.
/usr/src was not installed so I pulled it via svnlite following the handbook with:
svnlite checkout /usr/src

While /usr/src was downloading I prepared my kernelconfig file and called it SUPERMICRO.

I then cd /usr/src and got to work with make buildkernel KERNCONF=SUPERMICRO

But it immediately stops with:
make: don't know how to make buildkernel. Stop
make: Stop in /usr/src
There is no makefile in /usr/src. Only .svn, sbin/ and sys/.

System is up to date:
Userland is 11-RELEASE-p3
Kernel is 11-RELEASE-p2
I then issued freebsd-update fetch anyway, just to be sure.
src component not installed, skipped
Looking up mirrors... 4 mirrors found.
Fetching metadata signature for 11.0-RELEASE from done.
Fetching metadata index... done.
Inspecting system... done.
Preparing to download files... done.

No updates needed to update system to 11.0-RELEASE-p3.
Look at the first line, /usr/src does not seem to be recognized.

Here is some important output as I have found out from other threads:
# snvlite info /usr/src
Path: /usr/src
Working Copy Root Path: /usr/src
Relative URL: ^/stable/11
Repository Root:
Repository UUID: ccf9f872-aa2e-dd11-9fc8-001c23d0bc1f
Revision: 308904
Node Kind: directory
Schedule: normal
# uname -a
FreeBSD 11.0-RELEASE-p2 FreeBSD 11.0-RELEASE-p2 #0: Mon Oct 24 06:55:27 UTC 2016  amd64

I'm pretty sure it's something simple I did wrong...

Help appreciated.
That's a problem. Did you remove any old contents of /usr/src first? Please do that and check out again.
To expand on this, make sure that the /usr/src/.svn tree is also removed. Otherwise Subversion will get confused and think that files exist in /usr/src/ when they don't.
Good morning and thanks for your help.
I just removed everything from /usr/src and tried again.
The result is sadly the same as before, only .svn/, sbin/ and sys/ are downloaded to /usr/src/.

Is the command right, I used to fetch from the 11-stable branch? svnlite checkout /usr/src

At the end of the output, after fetching via svnlite there was this line (doesn't really look like an error message, is it?):
snv: E120106: ra_serf: The server sent a truncated HTTP requestresponse body.
There ist no custom configuration for svn or make, it is a pretty fresh install from about 2 weeks ago.

The Handbook says, that an appropriate svn-server is determined based on geolocation. Is that right? How do I know which server is used? I live in Norway. Is it possible the server does not have all the files?
Sometimes svn / svnlite aborts the transfer (network problems?) before it is finished. You should check that the last line of the output ends with
"checked out revision XXXX" or words to that effect.
If it don't, simply re-run the svnlite command again, until you have the needed data.
Ok, just solved the problem.
I run FreeBSD of a 32GB USB 3.0 flash drive on my laptop temporary. Quite fast on reading but laptop gets very unresponsive when building ports and there is a lot of writing.
After I could succesfully pull /usr/src on my server , I then tried about 10 times without luck on my laptop.
During the process I noticed that it sometimes stopped after 10min and the next try after 2min allready and that the svn server closed the connection once.
That made me think it MUST be the slow writing of the USB flash drive.
I than made a src/ directory on my server's nfs share and did:
svnlite checkout /[myserversnfsshare]/src
and it worked.
So the problem was only caused by sluggish write performance of the flash drive.
Thanks tingo. Yeah, just found what out it was kind of a network problem. Svn server got tired waiting for my slow flash drive.
When working with /usr/src/ and/or /usr/obj/ on NFS, something I bumped into more than once, make sure your times are synced! Or else you get weird and wonderful build errors that seemed to make no sense at all. As long as the build server and the NFS server both have the same time it'll work like a charm. A little slower of course due to NFS but it'll work just fine.
Thank you for the warning SirDice. I was about starting to build. Times are not perfectly in sync, with about a minute difference. I think it is about time to install FreeBSD to the internal SSD now.