• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Suspend/Resume problem...

Akwa

New Member


Messages: 4

#1
Hello,

Like lot of people, I have problems with the suspend/resume on my laptop.

The commands "zzz", "apm -Z" et "acpiconf -s3" works : the system goes to sleep.

Unfortunetely, the resume is imposssible.
When I turn on, led come on, fan come on, backlight's screen come on,
but the screen remains definitely black (with X or not).

The commands Ctrl+Alt+Backspace, Ctrl-Alt-Esc, Esc, Ctrl-Alt-F10, etc. are useless.
The link "http://www.freebsd.org/doc/handbook/acpi-debug.html" don't help no more. I trying to unload/reload the radeon driver in rc.suspend/rc.resume without sucess.

Config : Pentium 4 1.6Ghz, Chipset intel 845, ATI mobility Radon 7500. FreeBSD 8 Release.

If anybody has the beginning of a solution...
 

rhyous

Active Member

Thanks: 26
Messages: 137

#2
Have you installed radeontool-1.5 from ports?

I think when I had a T30 that used an ATI driver, I installed radeontool and used some command from that to sleep and wake up my video card.
 

Akwa

New Member


Messages: 4

#4
@ rhyous : thanks, I will try these radeontool.

@ richardpl : FreeBSD i386 SMP is for multiprocessor, I think. My laptop use an old Pentium 4, monocore and without HT. Then I think I don't use the SMP Kernel.
 

aragon

Daemon

Thanks: 272
Messages: 2,031

#5
Standard kernel is SMP enabled AFAIK. Maybe try with a custom kernel that has SMP disabled?

Some Pentium 4 CPUs are capable of 64bit - if yours is you can also try an AMD64 installation next.
 

richardpl

Aspiring Daemon

Thanks: 68
Messages: 841

#6
Akwa said:
@ richardpl : FreeBSD i386 SMP is for multiprocessor, I think. My laptop use an old Pentium 4, monocore and without HT. Then I think I don't use the SMP Kernel.
You use SMP kernel even if you have only one CPU. You do not need to create new kernel -> kern.smp.disabled=1 from loader(.conf)
 

Akwa

New Member


Messages: 4

#7
@aragon, @richardpl : thanks for your help. I will try all your solutions :)
(but as I know, my P4 is only 32 bits unfortunately)
 

Markand

Member

Thanks: 11
Messages: 91

#8
rhyous said:
Have you installed radeontool-1.5 from ports?

I think when I had a T30 that used an ATI driver, I installed radeontool and used some command from that to sleep and wake up my video card.
And what are you using ?

radeontool in /etc/rc.resume ?

radeontool light on ? radeontool dac on ?

Thanks.
 

ring_zero

Member

Thanks: 23
Messages: 67

#9
Suspend/Resume Fix

Akwa said:
Hello,

Like lot of people, I have problems with the suspend/resume on my laptop.

The commands "zzz", "apm -Z" et "acpiconf -s3" works : the system goes to sleep.

Unfortunetely, the resume is imposssible.
When I turn on, led come on, fan come on, backlight's screen come on,
but the screen remains definitely black (with X or not).

The commands Ctrl+Alt+Backspace, Ctrl-Alt-Esc, Esc, Ctrl-Alt-F10, etc. are useless.
The link "http://www.freebsd.org/doc/handbook/acpi-debug.html" don't help no more. I trying to unload/reload the radeon driver in rc.suspend/rc.resume without sucess.

Config : Pentium 4 1.6Ghz, Chipset intel 845, ATI mobility Radon 7500. FreeBSD 8 Release.

If anybody has the beginning of a solution...
Try this, it worked for me, although I had no backlight, and the screen most definitely did not come on at all when resuming.

Add the following code to /etc/sysctl.conf
Code:
hw.acpi.lid_switch_state=s3
hw.acpi.reset_video=1
And in order to get the mouse to work after resuming add the following to /boot/device.hints
Code:
hint.psm.0.flags="0x2000"
 

ring_zero

Member

Thanks: 23
Messages: 67

#10
Akwa said:
Hello,

Like lot of people, I have problems with the suspend/resume on my laptop.

The commands "zzz", "apm -Z" et "acpiconf -s3" works : the system goes to sleep.

Unfortunetely, the resume is imposssible.
When I turn on, led come on, fan come on, backlight's screen come on,
but the screen remains definitely black (with X or not).

The commands Ctrl+Alt+Backspace, Ctrl-Alt-Esc, Esc, Ctrl-Alt-F10, etc. are useless.
The link "http://www.freebsd.org/doc/handbook/acpi-debug.html" don't help no more. I trying to unload/reload the radeon driver in rc.suspend/rc.resume without sucess.

Config : Pentium 4 1.6Ghz, Chipset intel 845, ATI mobility Radon 7500. FreeBSD 8 Release.
If anybody has the beginning of a solution...
See here, the last post
 

Akwa

New Member


Messages: 4

#11
ring_zero said:
Try this, it worked for me, although I had no backlight, and the screen most definitely did not come on at all when resuming.
Thanks!

Unfortunately, my old laptop has no more FreeBSD for two years (the original message was posted in 2010)...
I hope that current laptops better implement ACPI, and that suspend/resume works better.
 

grahamperrin

Member

Thanks: 22
Messages: 86

#12
Laptops/HP_EliteBook_8570p - FreeBSD Wiki (2014-09-29) notes that with the HP EliteBook 8570p,

Suspend works, but resumes with a black screen
https://lists.freebsd.org/pipermail/freebsd-x11/2015-December/017023.html describes a workaround for the blackness with an HP EliteBook 850 G2 (IntelCorei7-5500U with Intel HD Graphics 5500). At its simplest:
  1. Control-Alt-F2
  2. Control-Alt-F9
Also, there's a request for special attention to FreeBSD Bug 188833 - [suspend/resume] Suspend/resume with Intel GMA HD 4000: AIGLX fails to restart