Support lxde?

It doesn't look like anyone has added LXDE to The Ports Collection, but that doesn't mean it shouldn't be able to be compiled manually.
 
it looks to me that all the pieces for lxde, except the wireless monitor are in the ports already. It doesn't seem like it would be that hard to diy.
 
What about porting it properly? I can commit the port for your then :)
 
Well, I could give it a shot if no one else wants to.

I got Screenlets working on FreeBSD 7, last week but most them are linux-centric. But I was thinking of working on some of those...time permitting.
 
I was just checking out the LXDE site, and it appears that only a meta port to install the components that are present in the ports is what would be required for an LXDE port.
 
Hi,

I think there are more things missing than just the meta port, since neither lxterminal nor lxlauncher is currently in the tree.

If no one is currently working on it, I'll give it a try and port them.
 
I missed those two. I decided to try and port screenlets in my free time, so I'm not working on this at all.

Go for it.
 
Meta port and lxterminal port submitted to GNATS

hi,

today I finished the ports and submitted them to GNATS. If someone wants to test them I attached them to this post.

simply unpack the archive and copy the ports to the /usr/ports/x11 directory.

lxterminal installs the vte-based terminal emulator of the lxde project.
lxde-meta installs all needed ports to run lxde.


feedback is very welcome.
 

Attachments

  • lxports.tar.bz2
    1.6 KB · Views: 218
Downloaded lxtask package, which is a nice application all by itself. It seemed to install fine, but funny thing was, it wouldn't show any tasks running or how much memory I was using. Anyone else run into an issue like this? Was thinking of rebuilding from the source code, but haven't had time to try it yet. Anyone have any experiences or advise to share with the lxtask port or package? Thanks.
 
Unable to choose LXDE at login time

I've been trying to install the meta port of LXDE, but I cannot find it as an option at login time. I am using KDM.

Thanks in advance/
Lasse
 
lm8 said:
Downloaded lxtask package, which is a nice application all by itself. It seemed to install fine, but funny thing was, it wouldn't show any tasks running or how much memory I was using. Anyone else run into an issue like this?
It probably uses /proc to get this information. Linux' /proc is different compared to FreeBSD's /proc.
 
Lasse said:
I've been trying to install the meta port of LXDE, but I cannot find it as an option at login time. I am using KDM.

Thanks in advance/
Lasse

Put this in your ~/.xinitrc:
Code:
exec startlxde
Then select "Custom" in KDM. If that doesn't work, place it also in ~/.xsession
 
~ is short-hand (an alias) for "user's home directory".

Thus, ~/.xinitrc refers to the .xinitrc file in the user's home directory.

There files are not created automatically, you need to create them yourself:
$ ee ~/.xinitrc
 
Unable to choose LXDE at login time

I have created .xinitrc and .xsession in /usr/home/larlun, but I am still not able to login with "Custom" in KDM.

What is wrong?

Lasse
 
Hmm, can you paste the content of those two files, please?
 
Hm, okay. Then let's try another approach. :)

Create the file /usr/local/kde4/share/apps/kdm/sessions/lxde.desktop with the following content:
Code:
[Desktop Entry]
Encoding=UTF-8
Name=LXDE Session
Comment=Use this session to run LXDE as your desktop environment
Exec=startlxde
Icon=
Type=Application

Then you should have an entry for LXDE after you restart KDM.
 
Unable to choose LXDE at login time

By the way. I found that I only needed to set .xsession to chmod 700 in order to start LXDE.

Thank you for all your help!
Lasse
 
Back
Top