Solved sound suddenly sounds a bit trebly

I first noticed it playing WAV or MP3 files, then checked online music and it also
[ maybe? ] seems 5 percent or so 'lighter' . However the local files are so light as to
sound like a whole other person singing. Could this be the result of a shared library [1. I checked, below... ]
upgrade, does anyone else notice it? { wasn' t that way three or so days ago, or ever }
.................................
alsa-libs [ /usr/local/share/alsa etc was recently updated, but I
upon a quick check found no files I could muster any expertise to check or alter a setting.
 
Last edited:
don't know. But that led me to dev.pcm.2.bitperfect=1 and another one like it which I should get around to checking, that I recently added.
............................
Reverted them, no effect. Only wavplay, audacious and mp3blaster seem
to be making sound too fast/high pitched that I've tested.
 
The treble voices, are again tenor as originally, using mplayer vs audacious, mp3blaster, wavplay...
 
Solved, with mplayer not mp3blaster... but I figured out how to describe it fully.
With mp3blaster, and the others mentioned above, a 28 year old singer sounds ten years old, but not as nice as if it were an actual ten year old singing. [ If I had time, I would and may build a kernel without sound drivers to check workarounds. ]
 
Do you have that problem when you play an .mp3 that was recorded in 48k instead of 44? Audacious will show you the resolution in its display.
 
Do you have that problem when you play an .mp3 that was recorded in 48k instead of 44? Audacious will show you the resolution in its display.
That partially solves it. mplayer
shows the mp3 as 48k while mp3blaster shows the exact
same file as 44k.
 
As bsduck already said, what you hear is 44.1k played at 48k speed. When you start mplayer from a command line like mplayer file.mp3 it will show you the output device it uses. Looks like this:
Code:
 AUDIO: 44100 Hz, 2 ch, floatle, 249.9 kbit/8.85% (ratio: 31232->352800)      ---> mp3 resolution is 44.1k.
Selected audio codec: [ffmp3float] afm: ffmpeg (FFmpeg MPEG layer-3 audio)
================================================
AO: [oss] 44100Hz 2ch s16le (2 bytes per sample)                              ---> mplayer uses OSS here.

If you look at Audacious' settings, tab Audio, which output plugin does it use? The same as mplayer or a different one?
 
audacious ... oss4 [ I could find no more info easily ]
[ singer sounds way younger as I stated ] [ also in mp3blaster

mplayer ... "Audio: 44100 ffmp3float..." AO: [oss] 48000 hz
libavformat v 58.76

[ not really concerned now though, the latter program is easy. ]
 
And with the new port musique, sounds play HALF SPEED. Wondering if it is due to the following in sysctl.conf:
Code:
dev.pcm.2.bitperfect=1
dev.pcm.1.bitperfect=1
hw.snd.verbose=4
 
From 'man sound':
dev.pcm.%d.bitperfect
Enable or disable bitperfect mode. When enabled, channels will
skip all dsp processing, such as channel matrixing, rate
converting and equalizing. The pure sound stream will be fed
directly to the hardware. If VCHANs are enabled, the bitperfect
mode will use the VCHAN format/rate as the definitive format/rate
target. The recommended way to use bitperfect mode is to disable
VCHANs and enable this sysctl. Default is disabled.

I don't know multimedia/musique, but it looks like some rate converting is missing now. IMO running in bitperfect mode is useful only when you use an external DAC.
 
Top