• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved [Solved] Xorg Some fonts blurry, others not



Thanks: 3
Messages: 88

Hi everyone!

Okay, so here I am today. I have FreeBSD 10.0 Release installed, and it works great! Except for one thing. For some reason, some of the fonts shown are blurry and others are not. It's subtle, but look at "Installation and Maintenance of FreeBSD Ports or Packages" (you may have to scroll down a bit), and compare that to "Installing and maintaining the FreeBSD Ports Collection or FreBSD Packages" right below it (in smaller text). I have put in a screenshot to show what I mean (the grey box in the upper right is my media player, it's not a glitch. Was blanked out for the screenshot by scrot). To fix this, I've tried deleting /usr/local/etc/fonts/conf.d/10-scale-bitmap-fonts.conf. Removing this caused some of the fonts to be crystal sharp, while others are still just as blurry as they used to be (originally, they were all blurry). I noticed that the proprietary Nvidia driver left fontpaths in my xorg.conf, so I commented them out. I think the fonts became a little sharper, but that could just as easily be the placebo effect. Some interesting notes, mainly two. One, as I stated before, I am running the proprietary driver (304, because my Quadro FX 1400 is too old for the newer one). Two, I actually have two monitors. One of them is a 1680x1050 DVi LCD, the other is a 1280x1024 VGA LCD. Since my card only has two DVI ports, I am using a DVI to VGA converter for my VGA screen. The fonts look equally blurry on both screens, so i think it's got something to do with Xorg, but I'm putting it in here just in case. Oh, and my window manager is i3, in case that helps. I'll show my xorg.conf, and I'll put in anything else you need. Thanks for reading :D !


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 310.14  (root@Neptune)  Sun Jul 20 20:29:51 EDT 2014

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"

#Section "Files"
    #FontPath        "/usr/local/lib/X11/fonts/misc/:unscaled"
    #FontPath        "/usr/local/lib/X11/fonts/100dpi/:unscaled"
    #FontPath        "/usr/local/lib/X11/fonts/75dpi/:unscaled"
    #FontPath        "/usr/local/lib/X11/fonts/misc/"
    #FontPath        "/usr/local/lib/X11/fonts/Type1/"
    #FontPath        "/usr/local/lib/X11/fonts/100dpi/"
    #FontPath        "/usr/local/lib/X11/fonts/75dpi/"
    #FontPath        "/usr/local/lib/X11/fonts/cyrillic/"
    #FontPath        "/usr/local/lib/X11/fonts/TTF/"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/sysmouse"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "keyboard"

Section "Monitor"
    # HorizSync source: xconfig, VertRefresh source: xconfig
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "CRT-1"
    HorizSync       31.0 - 80.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro FX 1400"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "CRT-1"
    Option         "metamodes" "CRT: 1280x1024_60 +0+0, DFP: 1680x1050_60 +1280+0; CRT: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24




Thanks: 19
Messages: 69

Re: Xorg Some fonts blurry, others not


Have you tried the following (as root)?
cd /usr/local/etc/fonts/conf.d
ln -s ../conf.avail/70-no-bitmaps.conf
I too had this issue and the above symbolic link fixed it.



Thanks: 3
Messages: 88

Re: Xorg Some fonts blurry, others not

Ah! Thanks! That was the fix! This is definitely going down in Notes.txt.... Thank you so much :beergrin ! It's been bugging me for a while now.