Solved [Solved] portmaster/mod_security FreeBSD-9.2

talsamon

Daemon

Reaction score: 283
Messages: 1,835

portmaster tells:

Code:
Shared object "libapr-1.so.5" not found, required by "libaprutil-1.so.0"
Shared object "libapr-1.so.5" not found, required by "libaprutil-1.so.0"
apxs:Error: Sorry, no shared object support for Apache.
apxs:Error: available under your platform. Make sure.
apxs:Error: the Apache module mod_so is compiled into.
apxs:Error: your server binary `/usr/local/sbin/httpd'..
"/usr/ports/Mk/bsd.apache.mk", line 290: warning: "/usr/local/sbin/apxs -q MPM_NAME" returned non-zero status

[
 
OP
talsamon

talsamon

Daemon

Reaction score: 283
Messages: 1,835

Re: portmaster FreeBSD-9.2

Try to reinstall www/mod_security:

Code:
/usr/ports/www/mod_security % sudo make install clean
Password:
Shared object "libapr-1.so.5" not found, required by "libaprutil-1.so.0"
Shared object "libapr-1.so.5" not found, required by "libaprutil-1.so.0"
apxs:Error: Sorry, no shared object support for Apache.
apxs:Error: available under your platform. Make sure.
apxs:Error: the Apache module mod_so is compiled into.
apxs:Error: your server binary `/usr/local/sbin/httpd'..
"/usr/ports/Mk/bsd.apache.mk", line 290: warning: "/usr/local/sbin/apxs -q MPM_NAME" returned non-zero status
===>  ap-mod_security-2.7.7_2 is marked as broken: : Error from bsd.apache.mk. apache is installed (or APACHE_PORT is defined) and port requires apache22 at least.
*** [install] Error code 1
 

wblock@

Beastie Himself
Developer

Reaction score: 3,682
Messages: 13,851

Re: portmaster/mod_security FreeBSD-9.2

I fought with devel/apr1 this morning. It works to rebuild it, and then everything that depends on it:
portmaster -r devel/apr1

For the other stuff, please update your ports tree.
 
OP
talsamon

talsamon

Daemon

Reaction score: 283
Messages: 1,835

Re: portmaster/mod_security FreeBSD-9.2

Thanks solved.
 
Top