So lost and confused

I scarcely know where to begin. I've gone pretty much with no sleep for days trying to get this to work that I'm not sure of half the things I have tried to fix it nor exactly how to describe it. I'll try my best. Thanks for your patience. I don't have a masters degree in computer science so I know I am in way over my head playing with this in the first place, hopefully somebody that does have one can make some sense of it all.
I have a Dell Latitude D620 I am trying to make use of. After many hours of head pounding and searching out videos on youtube, I have managed to get a gui. I have slim login and mate desktop up and running. Problem is that I don't have a proper resolution. My video card is Nvidia. Quadro NVS 110M/GeForce Go 7300. It is supposed to have a video resolution of 1280x800. I have 1024x768. I have the fatal error of Failed to get the size of gamma for output default. Monitor says default connected. I need the nvidia driver. There are literally hundreds of them. A few needed linux stuff installed it said. I tried that and ended up needing a linuxulator. Couldn't find that. I don't want to spend the rest of my life going in circles to make this work. If nobody can come up with some way to fix it, then this machine will find it's way to a dumpster very quickly. I've spent over a week trying to get linux or freebsd working right on this thing and I'm about done in. I realize that I am not really smart enough to ever figure this out on my own so I am hoping somebody out there can come up with a quick fix to install a driver. I am pretty sure I installed the 32 bit version so the 64 bit drivers won't work. I'm not sure where to check for what I have either. I downloaded the memory stick img file if that helps. Sorry if I don't have everything in the right places with the right names. I'm not very smart and get things backwards a lot so thanks in advance for your patience.
Your question and your problems are far too broad to help you. Reformat your drive. Read the Handbook. You never said if you read the Handbook. Then come back if you have problems but come back as the problems come up; not after you have a myriad of them.
Simply put, I need a driver for the above mentioned video card. I don't know which driver I need. Perhaps I should find something easier to work with. I did read the handbook. It didn't help. There is no xorg.conf file anymore and so all that was useless. I am about to just give up. I wanted to use some old laptops to use for writing and a bit of research on the go. I'd rather not take the Macbooks as they cost more and an old laptop is pretty disposable. Generally handbooks and man pages just give me a headache, I can't translate what they say into actual usage very well. Give me a video with step by step what to do or just give me simple steps of what to type where and I can get it.
Thanks but it failed. It won't load it. says sysctl: unkown oid 'compat.linux.osrelease' linuxulator is not (kld)loaded, exiting pkg:pRE-INSTALL script failed. I tried this before. I tried using xorg.conf but discovered xandr Sadly there is just no way to get around needing linux to make this card work. It appears to be the linux emulator that is failing. So, without linux in some form, it is never going to work. Shrug. I've fiddled with linux since 1998 or so and it used to be much much worse. I can remember spending most of a month trying to get it to recognize all the hardware and work but it never did. I think the first distro that actually worked for me was Ubuntu in 2005 or so. I'm testing out a lot of distros. For linux, I found windowmaker live. Debian based and everything looks to work right from boot. Next up is pcbsd. I figure I will see if their version will have the drivers for this installed already. It can't hurt and it might just work. Trying to breathe life into a bunch of old hardware to make it productive again. Thanks for the input, it is much appreciated.
says sysctl: unkown oid 'compat.linux.osrelease' linuxulator is not (kld)loaded, exiting pkg:pRE-INSTALL script failed.
I guess it's now a fatal error (or maybe it always was?). But running kldload linux prior to installing the driver should be all you need to do to fix it.

Can you try again?
Rick, you seem to know quite a few Linux distributions. Do the live CDs of those work on your laptop to your liking as is, even with the resolution you require? PC-BSD perhaps? If so, I personally recommend you just install one of those.

It's really hard to help someone not having the patience and willingness to dig into the dirt. No need to be a brain surgeon. Accepting not to have the right resolution at first, then find a way to fix it later as your skills improve is a good approach IMO. There's nothing wrong with 1024x768, nor 640x400. It's only temporary. Tobik's tip seems a good one to me too.

My PC has a Nvidia video card, and it's fine with FreeBSD. At first, the nouveau driver was installed, and that didn't work well. I installed the Nvidia driver from the Ports tree, actually all Nvidia related tools, erased everything nouveau I could find, and everything was great afterward. The driver is from Nvidia themselves, and supports lots of older Nvidia video cards, so it's the one to have. Ok, maybe I got lucky.

Good luck to you too!

Well, I have drifted about. I'm going with Salix on the netbook and either that or plain vanilla Slack on the other. I have a windoze program I have thousands invested in that I wished to work. I couldn't get it to do more than install and start on every distro I tried. I had all but given up on it but the netbook with Salix fired up the program, it never encountered the infamous can't find the internet to login message and gave me access to my resources. Of course the netbook is too low on storage to provide enough space to hold all the resources, but it worked. Sometimes you just get slapped in the head with the answer when you least expect it. :) There is something about Slack I've found over the years that always brings me back. Debian and Slack are the backbone of most all linux distros. Mostly Debian under the hoods of everything from Ubuntu to Knoppix to Mint. Slack is very close to BSD, I think in the way it feels. Obviously it isn't the same but it feels the same. Sorry, it's my creative side coming out... or I forgot to take my meds again... :p Not sure if that makes sense. It's like driving a Ford F250 and a Dodge 2500. Both 3/4 ton trucks but quite different. They both drive like a truck, though. Solid and something you can slam through potholes and over rocks without worry. That's BSD and Slack. 3/4 ton internet vehicles you cant damage too easily. Waving from left field. ;-)
Slack -hardy har har. I got all worked up for 14.2 and stuff I want is broke. I like the lack of systemd. That's it.
Save yourself some time and try Alpine. All these distro's trying to avoid systemd have issues in one area or another.
Resistance is futile.

If FreeBSD ever adopts binary system logs that will be my canary in the colemine.
Slackware is going nowhere. I'm stuck at a command line. I can start X. That all works. Wireless no. Trying to find anything written in English is pretty much impossible. I'll keep trying for a couple more hours to get it running but Salix or Vector I believe is the way for me to go. I haven't been able to figure out much about linux in 18 years so the problem is not the base distro but the top level stuff. I'm obviously too stupid to use anything too complicated. I know, RTFM. I have done that and all it does it get mixed in my head and get hopelessly screwed up. More than one computer made it to a dumpster that way. LOL I have a dead laptop behind me that succumbed to my attempting to get Winblows back on it and then linux. Hard drive is now fried completely. Nobody has a clue how that is even possible. I did it but no clue how. LOL 6 months old, too. Shrug. As long as it has an easy to use interface on it, but not really flashy, I'm good. Salix is like that. It just loads up and works. This, not so much. Yet they are both slackware. Hmmmmm. I'll go look at Alpine but something tells me that like this thing I am looking at, you have to be either a genius, have an advanced degree or both to make it work. Slack wireless is a nightmare.
Update: I kicked Freddy's sorry butt all the way down Elm St to Main. Ha! I win. Wireless works, Video works. Just need the program to work and I'll keep this thing to learn on. I don't need much. Important stuff is working, just needs fine tuning a bit. This is strangely great fun when stuff actually works like this. :)