smbd module acl error

BloodyIron

New Member


Messages: 1

#1
I'm not sure if this is the right section, because it is about my SMBD on my ZFS pool.

I keep getting the following in my /var/log/messages :

Code:
Nov 19 09:22:31 XXXXXX smbd[27866]: [2012/11/19 09:22:31.372255,  0] modules/vfs_posixacl.c:170(smb_ace_to_internal)
Nov 19 09:22:31 XXXXXX smbd[27866]:   unknown tag type 64
I tried looking this up, and the only thing I could find is disabling the ACL in SMBD and recompiling SMBD.

However, my concern is that this will impair the ability to authenticate AD users for the folders. Our primary authentication is with AD (Active Directory 2003). On this ZFS pool we have folder permissions corresponding to groups found in our domain which are authenticated through samba.

Any ideas?
 

cydnub

New Member


Messages: 2

#3
That fixed it for me! I was looking into vfs_posixacl.c and noticed that there was no flow (starting at line 170) for tag value ACL_EVERYONE (in acl.h, where 0x40 = 64) which was causing the default case to be executed and that debug message to be returned. I was thinking I was going to have to add a line for case ACL_EVERYONE myself and compile it, but thankfully your options did the trick! Thanks! :)
 

mnvn

Member

Thanks: 4
Messages: 23

#4
I'm very glad that I was able to help you :).

I've also noticed, that options from [share] can be put in [global] - useful if we've got ZFS everywhere, no space wasting in share definitions.
 

jneibel

New Member


Messages: 1

#5
I'm a newbie here, but how do I edit the configuration to resolve this error message? I am running FreeNAS 9.2 and using Windows and Unix shares only.
 

npoellmann

New Member


Messages: 1

#6
Your configuration works very well for us also on:
  • FreeBSD 10.0-RELEASE
  • samba41-4.1.11
  • ZFS file system version: 5, configured as mirror-0
  • WDC SATA 3.x device, 1TB disks

All ACL warnings in the logs disappeared.

BTW: the configuration as listed above: our customer reports, that performance and speed of his Samba file server is great. As he said "5 times faster than before".

Thank you,

Norbert Poellmann
 
Top