• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

sierra 320u

humand

New Member


Messages: 16

#26
bsdnub,
for bigpond you need to replace telstra.internet with telstra.bigpond under the AT+CGDCONT line in ppp.conf
also, be prepared to replace the following with your login username/pass (if you were provided these by your provider) under set authname and set authkey in ppp.conf.
 

bsdnub

Member

Thanks: 1
Messages: 30

#27
humand,

I did change telstra.internet with telstra.bigpond. also i put in my username in the box and same with password.

But under PPoE Device i click the down arrow and select cuaU0.3 and save it, then close the connection box and reopen it bge0 is selected.

How do i make cuaU0..3 kept as the PPoE Device selection ?
 

humand

New Member


Messages: 16

#28
bsdnub,

in the connection manager or the GUI you're trying to set up the connection from, you need to configure a ppp not ppoe connection. although similar, ppoe uses an ethernet card, which you dont want.

what happens if you just save the new ppp.conf (back up the existing first) under /etc/ppp/ppp.conf and run ppp -ddial provider (where provider is the alias associated with your provider settings from ppp.conf)
 

bsdnub

Member

Thanks: 1
Messages: 30

#29
humand,

I have edited ppp.conf and typed in what you said,

Code:
default:
 set log Phase Chat LCP IPCP CCP tun command
 set device /dev/cuaU0.3
 set timeout 180

provider:
 set speed 921600
 set timeout 0
 set authname wapuser1
 set authkey wap
 set dial "ABORT BUSY TIMEOUT 3 \
        \"\" \
        AT OK-AT-OK \
        AT+CFUN=1 OK-AT-OK \
        AT+CMEE=2 OK-AT-OK \
        AT+CSQ OK \
        AT+CGDCONT=1,\\\"IP\\\",\\\"telstra.internet\\\" OK \
        ATD*99# CONNECT"
 enable dns
 resolv writable
 set ifaddr 10.0.0.1/0 10.0.0.2/0 255.255.255.255 0.0.0.0
 add default HISADDR
but not sure how to use ppp -ddial provider.

Do i do that in the terminal ?
 

humand

New Member


Messages: 16

#30
bsdnub,

forget about the connection manager, it has some odd behaviour when it comes to 3g ppp. uncheck the "always on connection" and reboot
just save the ppp.conf file that i gave you in the last post to /etc/ppp/ppp.conf
make sure you change set authname and set authkey to reflect your login information.
in a terminal, run the following: ppp -ddial provider
check with ifconfig if tun0 comes up (hopefully with an IP address)
let me know the result
 

bsdnub

Member

Thanks: 1
Messages: 30

#31
To change my set authname and set authkey what do i put there ? i`m a dumbo at this stuff.

Code:
ppp -ddial provider:

Working in ddial mode
Using interface tun2
Code:
ifconfig:

tun0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> metric 0 mtu 1500
        options=8000<LINKSTATE>
        nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
        Opened by PID 6280
tun1: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> metric 0 mtu 1500
        options=8000<LINKSTATE>
        nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
        Opened by PID 6393
tun2: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> metric 0 mtu 1500
      options=8000<LINKSTATE>
      nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
      Opened by PID 6530
 

humand

New Member


Messages: 16

#32
it should be something like:

Code:
set authname bsdnub@bigpond.com
set authkey yourpassword
replace "bsdnub@bigpond.com" and "yourpassword" with whatever your wireless provider gave you to use. (you should also be able to give them a call to find them out.)
only run the "ppp -ddial provider" command once, i see you ran it 3 times since you have tun0, tun1, tun2.
first edit authname and authkey, then reboot so your previous tun interfaces will go away, then run the ppp -ddial provider command once, wait a few seconds and run ifconfig to check the status of the tun interface
 

bsdnub

Member

Thanks: 1
Messages: 30

#33
ok i edited ppp.conf and added my username and password like you said and rebooted my pc.

Then i ran pp -ddial provider and waited a few seconds then typed

Code:
ifconfig:

  flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> metric 0 mtu 1500
    options=8000<LINKSTATE>
    nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
    Opened by PID 3051
 

humand

New Member


Messages: 16

#37
reboot so your tun device will go away
overwrite your /etc/ppp/ppp.conf with the one i gave you and modify the authname and authkey with your provider info (the reason i'm asking you to do this again is because the connection manager might overwrite it on reboot)
in terminal type ppp -ddial provider
wait a few seconds and do an ipconfig to check the tun interface
if it does not have an ip, see if theres anything written in /var/log/ppp.log and if yes post the last screen

i think you're close at this point
 

bsdnub

Member

Thanks: 1
Messages: 30

#38
I did reboot and overwrite the /etc/ppp/ppp.conf and modified the authname and authkey with my provider info.

Typed ppp -ddd provider and then ifconfig and it has no ip address. Also /var/log/ppp.log is still empty.

Should i have the 320U plugged in when i do ppp -ddd provider and then ifconfig ?
 

bsdnub

Member

Thanks: 1
Messages: 30

#40
humand,

I plugged the Sierra 320U in and rebooted my pc, once pcbsd finished loading up i was connected to the net.

So i am now connected but loading my home page or trying to download firefox is really slow. Any way to make my speed quicker ?

What i did do was edit /etc/resolv.conf and removed nameserver 61.9.194.49 and 61.9.195.193 and added Dnsadvantage 156.154.70.1 and 156.154.71.1 but nameserver keeps coming back.

Tried to make a script named dhclient-enter-hooks, to stop nameserver keep loading on every reboot, but don`t know hot to make a script.

I searched how to do it but still not sure how to do it.
 

humand

New Member


Messages: 16

#41
do not edit /etc/resolv.conf as it's being updated by the ppp script when you successfully connect with your aircard.

add this line to your ppp.conf, under enable dns:
Code:
set dns 156.154.70.1
do not change the word "nameserver" from your /etc/resolv.conf file, as it's a keyword.
how do your speeds look like when connected with the aircard?
 

bsdnub

Member

Thanks: 1
Messages: 30

#42
I added set dns 156.154.70.1 to ppp.conf under enable dns.

My downloads and web pages load alot quicker now.

humand & PseudoCylon thanks for all your help connecting me to the net.

How do i mark this post as SOLVED ?
 

wblock@

Administrator
Staff member
Administrator
Moderator
Developer

Thanks: 3,579
Messages: 13,850

#43
Edit the first post and use the drop-down menu to set it to Solved.
 
Top