Setting up lagg interface

Sebulon

Aspiring Daemon

Thanks: 128
Messages: 709

#1
Hi,

last week, it was the first time for me setting up a lagg interface with a cisco switch and had this page from the handbook as a guide:
Link Aggregation and Failover

I had troubles getting everything to work because the lagg interface always showed "no carrier" as status and couldn´t get an address. After much googling, I found the reason for this is because you have make the laggports "up" before you create the lagg interface.

The rest went off without a hitch and it was so cool to see everything "just work". You really got double the perfomance and perfect failover!

If this had been explained in the handbook, it would have saved me half a day´s worth of troubleshooting.

Correct approach:
Code:
# ifconfig em0 up
# ifconfig em1 up
# ifconfig lagg0 create
# ifconfig lagg0 up laggproto lacp laggport em0 laggport em1
/etc/rc.conf:
Code:
ifconfig_em0="up"
ifconfig_em1="up"
cloned_interfaces="lagg0"
ifconfig_lagg0="up laggproto lacp laggport em0 laggport em1 DHCP"
I think it would make things much easier for other people in that situation, if this was explained on that page. How does that sound?

/Sebulon
 

DutchDaemon

Administrator
Staff member
Administrator
Moderator
Developer

Thanks: 2,656
Messages: 11,225

#2
You should probably file a PR in the 'docs' section to get this noticed by someone editing the Handbook.
 
OP
OP
Sebulon

Sebulon

Aspiring Daemon

Thanks: 128
Messages: 709

#3
@Dutchdaemon

That sounds like a plan. Do you have an example of such a person?

/Sebulon
 
OP
OP
Sebulon

Sebulon

Aspiring Daemon

Thanks: 128
Messages: 709

#6
I also thought it might be of interest for some to know that I've set this up at home, but with a Netgear GS108T-200 for about 110$, instead of spending lots on a cisco or hp, which would be like swatting a fly with a cannon =)

If anyone else wants to try and has questions, I'll be happy to help.

/Sebulon
 

Terry_Kennedy

Aspiring Daemon

Thanks: 263
Messages: 883

#7
Sebulon said:
I also thought it might be of interest for some to know that I've set this up at home, but with a Netgear GS108T-200 for about 110$, instead of spending lots on a cisco or hp, which would be like swatting a fly with a cannon =)
If anyone does want to set this up on a Cisco, here's the config:
Code:
!
interface Port-channel1
 description LACP channel to FreeBSD system
 switchport               [i]<-- Only needed on Catalyst 45xx/49xx, not on 3750[/i]
 switchport mode access
!
interface GigabitEthernet1/0/1
 description FreeBSD system igb0
 switchport mode access
 channel-protocol lacp
 channel-group 1 mode active
!
interface GigabitEthernet1/0/2
 description FreeBSD system igb1
 switchport mode access
 channel-protocol lacp
 channel-group 1 mode active
 
Top