Server compromised ?

unficyp

New Member

Thanks: 1
Messages: 8

#1
Hi all,
just tried to install a client for our backup software:

Code:
root@ns1:/usr/home/gweber # pkg search bareos
pkg: Newer FreeBSD version for package p5-Finance-Bitcoin:
- package: 1102000
- running kernel: 1101001
pkg: repository FreeBSD contains packages for wrong OS version: FreeBSD:11:amd64
p5-Finance-Bitcoin ?

uname -a shows:

Code:
FreeBSD ns1 11.1-RELEASE-p4 FreeBSD 11.1-RELEASE-p4 #0: Tue Nov 14 06:12:40 UTC 2017     root@amd64-builder.daemonology.net:/usr/obj/usr/src/sys/GENERIC  amd64
pkg info shows:

Code:
root@ns1:/var/db/pkg # pkg info
bind912-9.12.0                 BIND DNS suite with updated DNSSEC and DNS64
boost-libs-1.66.0              Free portable C++ libraries (without Boost.Python)
dhcping-1.2                    Send DHCP request to DHCP server for monitoring purposes
fusefs-libs-2.9.5              FUSE allows filesystem implementation in userspace
gettext-runtime-0.19.8.1_1     GNU gettext runtime libraries and programs
glib-2.50.3,1                  Some useful routines of C programming (current stable version)
icu-60.2_1,1                   International Components for Unicode (from IBM)
idnkit-1.0_7                   Library to handle internationalized domain names
indexinfo-0.3.1                Utility to regenerate the GNU info page index
isc-dhcp43-server-4.3.6_2      ISC Dynamic Host Configuration Protocol server
json-c-0.13                    JSON (JavaScript Object Notation) implementation in C
libdnet-1.12_1                 Simple interface to low level networking routines
libedit-3.1.20170329_2,1       Command line editor library
libffi-3.2.1_2                 Foreign Function Interface
libiconv-1.14_11               Character set conversion library
libmspack-0.5                  Library for Microsoft compression formats
libxml2-2.9.7                  XML parser library for GNOME
lmdb-0.9.21,1                  OpenLDAP Lightning Memory-Mapped Database
lua52-5.2.4                    Small, compilable scripting language providing easy access to C code
monit-5.25.0                   Unix system management and proactive monitoring
open-vm-tools-nox11-10.2.0_2,2 Open VMware tools for FreeBSD VMware guests
pcre-8.40_1                    Perl Compatible Regular Expressions library
perl5-5.24.3                   Practical Extraction and Report Language
pkg-1.10.4                     Package manager
postgresql95-client-9.5.10     PostgreSQL database (client)
protobuf-3.5.1.1               Data interchange format library
py27-ply-3.10_1                Python Lex-Yacc
py27-setuptools-38.2.5         Python packages installer
python27-2.7.14_1              Interpreted object-oriented programming language
readline-7.0.3_1               Library for editing command lines as they are typed
zabbix34-agent-3.4.6           Enterprise-class open source distributed monitoring (agent)
Do I have a problem here ?

Thanks in advance,
gerald
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 6,617
Messages: 28,158

#2
Do I have a problem here ?
Yes, you need to update to 11.2, 11.1 is end-of-life and not supported any more. Not really a big problem, upgrading is easy with freebsd-update(8) and will only take a couple of minutes (downloading may take a while depending on your internet connection).
 

yuripv

Active Member

Thanks: 61
Messages: 146

#3
No, it's just (not so) random package from the database you downloaded, used to compare the version used to build packages and what you are currently running.
 
Top