Segmentation fault: 11 (core dumped). LXDE, obconf, lxpanel


After many hours of installing my first FreeBSD I decided to install X's. I chose LXDE and Openbox. When I try to run Openbox everything's ok. But when I try to run lxsession I get:
Segmentation fault: 11 (core dumped)
I get same error message when I try to run obconf and lxpanel too.

I use: FreeBSD 7.1 amd64, lxsession-lite-0.3.6, lxpanel 0.3.7 and obconf-2.0.3_1

Coredumps are here:

I'll be thankfull if anyone could help me.
Dzięki... I mean thank you ;)
I read that and I have not overclocked CPU, my PC is well cooled, I'm newbie and I can't use gdb only what I did using gdb is run and backtrack:
Starting program: /usr/local/bin/lxsession 
(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...
Program received signal SIGSEGV, Segmentation fault.
0x0000000800ac4952 in strlen () from /lib/
It's a magic for me.
I got lots of 'Segmentation fault: 11 (core dumped)' too, memtest didn't find any problems but actually one of my memory banks was faulty. I removed it and now everything is fine.
I got segfault only on amd64
Under i386 obconf runs OK

both 8.0-RELEASE on the same machine.

something with RAM or amd64 like bug?
i'll compile i386 with PAE and test the obconf again
It's a bug in obconf, I get segfaults on AMD64 with this application on two different machines. Most segfaults I know of in FreeBSD aren't caused by hardware errors but incompatibilities (99% of the software is written for Linux).

FYI: filed a PR.
Tried running i386 binary of obconf(from i386 chroot) on amd64 FreeBSD kernel, it still segfaults. Probably a big bug in the code somewhere regarding memory handling, seen this happen alot with various software when bug shows itself only on other architectures/platforms where memory addresses are aligned differently.
More than on year later and this problem persists. My obconf and lxpanel segfault and dump core (amd64). They're not even members of the same project, to share code or something.

Is it my impression or the software/workflows which are not written in the "bible" are neglected second-hand/outsider stuff?