Solved Screensaver timeout

s5e

Member

Reaction score: 3
Messages: 52

How to set screensaver timeout to 60min? Vidcontrol does not work.
 

Minbari

Well-Known Member

Reaction score: 178
Messages: 350

Did you try to edit .xscreensaver and set timeout: 0:60:00? Works fine on i3.
 
OP
OP
S

s5e

Member

Reaction score: 3
Messages: 52

Did you try to edit .xscreensaver and set timeout: 0:60:00? Works fine on i3.
I don't have xscreensaver installed. I'm not sure is dwm handling it. Dwm needs to compile every time you make changes to it and I've installed it from ports, so I can't compile it. Maybe I should try another tiling wm..
 

Minbari

Well-Known Member

Reaction score: 178
Messages: 350

Now I see what you mean by screensaver, you wanted to turn off the display power after 60 minutes. That can be done with xset and its independent of what WM you are using.
eg. xset s 3600 3600

To make the changes permanent add that command in your .xinitrc before the line with exec dwm.

offtopic:
Speaking of dwm, it's too spartan and lack some features by default and without applying patches it's kinda annoying to use it at least for my taste, but when applying to much patches it break and you have to do it manually and that is time consuming and is not worth the effort.
 
  • Thanks
Reactions: s5e
OP
OP
S

s5e

Member

Reaction score: 3
Messages: 52

Now I see what you mean by screensaver, you wanted to turn off the display power after 60 minutes. That can be done with xset and its independent of what WM you are using.
eg. xset s 3600 3600

To make the changes permanent add that command in your .xinitrc before the line with exec dwm.

offtopic:
Speaking of dwm, it's too spartan and lack some features by default and without applying patches it's kinda annoying to use it at least for my taste, but when applying to much patches it break and you have to do it manually and that is time consuming and is not worth the effort.
Thanks, good to know. I already moved from dwm to dspwm. Let's see is it better choice for me.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,556
Messages: 30,264

Just for your information, it's probably DPMS that's switching the monitor off.
 
OP
OP
S

s5e

Member

Reaction score: 3
Messages: 52

hmm.. I don't have xset either. Is possible to set new timeout without xset or do I need to install it?
 

Minbari

Well-Known Member

Reaction score: 178
Messages: 350

hmm.. I don't have xset either. Is possible to set new timeout without xset or do I need to install it?
It's that hard to install it?
pkg install xset or cd /usr/ports/x11/xset/ && make install clean
 
OP
OP
S

s5e

Member

Reaction score: 3
Messages: 52

It's that hard to install it?
pkg install xset or cd /usr/ports/x11/xset/ && make install clean
No. I try to keep my system minimal, but this seems to be needed widely. with fonts etc.. I'll install it.
 

ILUXA

Aspiring Daemon

Reaction score: 434
Messages: 679

Just install x11/xscreensaver, then add xscreensaver -nosplash to
your WM autostart script (google it, to add it to your dwm WM, you'll need to rebuild
it with patch), then relogin. Then you'll be able to configure your screen power
management with xscreensaver-demo command.
 

Minbari

Well-Known Member

Reaction score: 178
Messages: 350

Just install x11/xscreensaver, then add xscreensaver -nosplash to
your WM autostart script (google it, to add it to your dwm WM, you'll need to rebuild
it with patch), then relogin. Then you'll be able to configure your screen power
management with xscreensaver-demo command.
Installing x11/xscreensaver means extra stuff and he wants a "minimal" system, so the best solution it's with dpms (xset).
 

Vull

Well-Known Member

Reaction score: 119
Messages: 285

Found this trick on a messageboard somewhere some time back, and it has worked pretty well for me on most, if not all, of the DE's I've tried it with. Just had to add the file /usr/local/etc/X11/xorg.conf.d/serverflags.conf with these contents:
Code:
Section "ServerFlags"
#...
Option "BlankTime" "60"
Option "StandbyTime" "0"
Option "SuspendTime" "0"
Option "OffTime" "0"
EndSection
Note that "0" in this context is the code for "never" and not for "0 minutes"
 
  • Thanks
Reactions: s5e
OP
OP
S

s5e

Member

Reaction score: 3
Messages: 52

Found this trick on a messageboard somewhere some time back, and it has worked pretty well for me on most, if not all, of the DE's I've tried it with. Just had to add the file /usr/local/etc/X11/xorg.conf.d/serverflags.conf with these contents:
Code:
Section "ServerFlags"
#...
Option "BlankTime" "60"
Option "StandbyTime" "0"
Option "SuspendTime" "0"
Option "OffTime" "0"
EndSection
Note that "0" in this context is the code for "never" and not for "0 minutes"
This seems to work, thanks!
 
Top