screen resolution

Newbie here. I recently installed freebsd on a laptop and I'm trying to set it up with dwm. My main problem is the screen resolution at this point.

xrandr output:
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 8192 x 8192
LVDS connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1366x768      60.01 +
   1280x720      59.86  
   1152x768      59.78  
   1024x768      59.92*
   800x600       59.86  
   848x480       59.66  
   720x480       59.71  
   640x480       59.38  

HDMI-0 connected 1024x768+0+0 (normal left inverted right x axis y axis) 509mm x 286mm
   1920x1080     60.00 +
   1680x1050     59.88  
   1280x1024     75.02    60.02  
   1440x900      59.90  
   1280x960      60.00  
   1024x768      75.08    70.07    60.00*
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   640x480       75.00    72.81    66.67    60.00  
   720x400       70.08  
VGA-0 disconnected (normal left inverted right x axis y axis

and so it looks like I'm on 1024x768.

I'm trying to switch to 1920x1080. I'm not sure if the laptop's screen is causing a problem but it's closed and I am not planning on using it while attached to my external monitor.

Worth mentioning might be that I was looking at pciconf -l and it was listing my hardware with all sorts of details and, while looking at it, x just closed. Since then, I am getting a different output such as:

hostb0@pci0:0:0:0:   class=0x060000 card=0x1bf21043 chip=0x96011022 rev=0x00 hdr=0x00
pcib1@pci0:0:2:0:   class=0x060400 card=0x1bf21043 chip=0x96031022 rev=0x00 hdr=0x01
pcib2@pci0:0:4:0:   class=0x060400 card=0x1bf21043 chip=0x96041022 rev=0x00 hdr=0x01
pcib3@pci0:0:5:0:   class=0x060400 card=0x1bf21043 chip=0x96051022 rev=0x00 hdr=0x01
ahci0@pci0:0:17:0:   class=0x010601 card=0x13131043 chip=0x43911002 rev=0x00 hdr=0x00
ohci0@pci0:0:18:0:   class=0x0c0310 card=0x13131043 chip=0x43971002 rev=0x00 hdr=0x00
ehci0@pci0:0:18:2:   class=0x0c0320 card=0x13131043 chip=0x43961002 rev=0x00 hdr=0x00
ohci1@pci0:0:19:0:   class=0x0c0310 card=0x13131043 chip=0x43971002 rev=0x00 hdr=0x00
ehci1@pci0:0:19:2:   class=0x0c0320 card=0x13131043 chip=0x43961002 rev=0x00 hdr=0x00
none0@pci0:0:20:0:   class=0x0c0500 card=0x00000000 chip=0x43851002 rev=0x42 hdr=0x00
hdac1@pci0:0:20:2:   class=0x040300 card=0x11b31043 chip=0x43831002 rev=0x40 hdr=0x00
isab0@pci0:0:20:3:   class=0x060100 card=0x13131043 chip=0x439d1002 rev=0x40 hdr=0x00
pcib4@pci0:0:20:4:   class=0x060401 card=0x00000000 chip=0x43841002 rev=0x40 hdr=0x01
ohci2@pci0:0:22:0:   class=0x0c0310 card=0x13131043 chip=0x43971002 rev=0x00 hdr=0x00
ehci2@pci0:0:22:2:   class=0x0c0320 card=0x13131043 chip=0x43961002 rev=0x00 hdr=0x00
hostb1@pci0:0:24:0:   class=0x060000 card=0x00000000 chip=0x12001022 rev=0x00 hdr=0x00
hostb2@pci0:0:24:1:   class=0x060000 card=0x00000000 chip=0x12011022 rev=0x00 hdr=0x00
hostb3@pci0:0:24:2:   class=0x060000 card=0x00000000 chip=0x12021022 rev=0x00 hdr=0x00
hostb4@pci0:0:24:3:   class=0x060000 card=0x00000000 chip=0x12031022 rev=0x00 hdr=0x00
hostb5@pci0:0:24:4:   class=0x060000 card=0x00000000 chip=0x12041022 rev=0x00 hdr=0x00
vgapci0@pci0:1:0:0:   class=0x030000 card=0x1bf21043 chip=0x68e01002 rev=0x00 hdr=0x00
hdac0@pci0:1:0:1:   class=0x040300 card=0x1bf21043 chip=0xaa681002 rev=0x00 hdr=0x00
ath0@pci0:4:0:0:   class=0x028000 card=0x10891a3b chip=0x002b168c rev=0x01 hdr=0x00
none1@pci0:5:0:0:   class=0x088000 card=0x1a071043 chip=0x2382197b rev=0x80 hdr=0x00
sdhci_pci0@pci0:5:0:2:   class=0x080501 card=0x1a071043 chip=0x2381197b rev=0x80 hdr=0x00
none2@pci0:5:0:3:   class=0x088000 card=0x1a071043 chip=0x2383197b rev=0x80 hdr=0x00
none3@pci0:5:0:4:   class=0x088000 card=0x1a071043 chip=0x2384197b rev=0x80 hdr=0x00
jme0@pci0:5:0:5:   class=0x020000 card=0x19051043 chip=0x0250197b rev=0x03 hdr=0x00

Any help is appreciated. Thanks!
Last edited by a moderator:
fantastic, that did it! Can you tell me how I can set it to be so at boot, for every user?

I found that one can edit /usr/local/etc/X11/xorg.conf.d/screen-resolution.conf (I think the file name here doesn't matter but I could be wrong!) and I added the following:

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        SubSection "Display"
        Modes      "1920x1080"

the problem is that although I'm at full screen, my windows only open within the laptop's screen area (or so it seems), so I'm trying to figure out how to disable the laptop screen when starting x.

Anyone know how? Thanks
Last edited by a moderator:
What I ended up doing, although it doesn't work at boot, is add tobik's line to my .xinitrc. Whenever I start X, now, everything comes up as it should.
Last edited by a moderator: