Solved same lxde on different os show different gui

mybsd

Member

Reaction score: 2
Messages: 22

The lxde environment in debian10:

close-debian.jpg


It contains many sub-manual such as :shutdow,reboot,suspend,switch user,lock screen,logout,cancel.

The lxde in freebsd13.

close-bsd.jpg


It contains so little sub-manual:lock screen,logout,cancel.

How can add more sub-manual in freebsd ?
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,052
Messages: 38,506

It's probably because you didn't start a ConsoleKit session when starting LXDE. How are you starting X? With startx? Or through a display manager? If startx, what's in ~/.xinitrc?
 

astyle

Aspiring Daemon

Reaction score: 386
Messages: 871

It's also probably compiled with different options. FreeBSD packages tend to be compiled with rather minimal options, compared to Linux, even when source tarballs are the same. FreeBSD does offer /usr/ports so that it's easier to compile the package with as many options as you like. :)
 
OP
M

mybsd

Member

Reaction score: 2
Messages: 22

cat .xinitrc
exec /usr/local/bin/startlxde --with-ck-launch
Is there something wrong in .xinitrc?

I install it with `sudo pkg install lxde-mate`.

ls /usr/ports
accessibility converters german Makefile portuguese UPDATING
arabic COPYRIGHT GIDs math print vietnamese
archivers databases graphics misc README www
astro deskutils hebrew Mk russian x11
audio devel hungarian MOVED science x11-clocks
base distfiles irc multimedia security x11-drivers
benchmarks dns japanese net shells x11-fm
biology editors java net-im sysutils x11-fonts
cad emulators Keywords net-mgmt Templates x11-servers
CHANGES finance korean net-p2p textproc x11-themes
chinese french lang news Tools x11-toolkits
comms ftp LEGAL polish UIDs x11-wm
CONTRIBUTING.md games mail ports-mgmt ukrainian
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,052
Messages: 38,506

With LXDE running, open a terminal and enter ck-list-sessions. What does that output?
 

astyle

Aspiring Daemon

Reaction score: 386
Messages: 871

Is the configuration right?
Well, there, you go... It looks like you don't have ConsoleKit, which is needed by LXDE to be able to create more submenus on the logout screen. Try # pkg install sysutils/consolekt2, and reboot.
 

Vull

Aspiring Daemon

Reaction score: 372
Messages: 646

Is the configuration right?
Not ck-list-session - the correct spelling is ck-list-sessions with "s" at the end.
Code:
len@mate:~ $ ck-list-sessions
Session1:
    unix-user = '1001'
    realname = 'len'
    seat = 'Seat1'
    session-type = 'unspecified'
    session-class = 'user'
    session-state = 'active'
    active = TRUE
    x11-display = ':0'
    x11-display-device = '/dev/ttyv8'
    display-device = '/dev/ttyv7'
    remote-host-name = ''
    is-local = TRUE
    on-since = '2021-07-23T15:32:23.477266Z'
    login-session-id = ''
    XDG_RUNTIME_DIR = '/var/run/user/1001'
    VTNr = '9'
len@mate:~ $
If you want to see shutdown options in lxde, you probably need to install a display manager instead of starting your sessions using ~/.xinitrc. Debian uses lightdm as its display manager.

Try these two commands:

sudo pkg install lightdm lightdm-gtk-greeter
sudo sysrc lightdm_enable="YES"

Then reboot, and you should see the options you're missing in lxde.
 

Vull

Aspiring Daemon

Reaction score: 372
Messages: 646

Well, there, you go... It looks like you don't have ConsoleKit, which is needed by LXDE to be able to create more submenus on the logout screen. Try # pkg install sysutils/consolekt2, and reboot.
I didn't know about this port, thanks. Perhaps then this alone would be adequate, if mybsd prefers to launch his sessions with startx rather than with a display manager? I notice now that lightdm lists consolekit2 as one of its dependencies:
Code:
len@mate:~ $ pkg info -r sysutils/consolekit2
consolekit2-1.2.3:
    lightdm-1.30.0_3
    mate-session-manager-1.24.3
len@mate:~ $
 

astyle

Aspiring Daemon

Reaction score: 386
Messages: 871

Not ck-list-session - the correct spelling is ck-list-sessions with "s" at the end.
Yeah, I somehow missed that myself. Good thing there's more than one set of eyes/brains to look at the problem.
 
Top