Solved samba 3.6 is failed

The problem is happened after I upgrade samba 3.6 to latest version samba36-3.6.25_3 by pkg upgrade.

When I tried to start samba service by $ sudo /usr/local/etc/rc.d/samba start

The system response was:
Performing sanity check on Samba configuration: OK
smbd not running? (check /var/run/samba/
Stopping nmbd.
Removing stale Samba tdb files: ... done
Starting nmbd.
Starting smbd.
/lib/ version FBSD_1.4 required by /usr/local/sbin/smbd not found
/usr/local/etc/rc.d/samba: WARNING: failed to start smbd

My system is: 10.0-RELEASE

Thanks in advance for suggestion.
I had a similar problem the other day. I wanted to install a package (can't remember which now) on a 10.2 machine and it wanted to upgrade pkg. As soon as pkg was upgraded, it started complaining about a library file and refused to run. I ended up having to use ports.

In the end I had a suspicion that the package it had downloaded was only compatible with 10.3 and not the version I was running, although I can't verify that. (This is purely due to the fact that I could only find one reference online to a similar error, and it was due to someone building packages on 10.3 and trying to install them on 10.2).

I ended up using freebsd-update() to upgrade the entire system to 10.3.
I was experiencing similar issues on the weekend (Samba 4.3 and Samba 4.4 binary ports). Yesterday (or some time between when I upgraded on the weekend and yesterday) the binary ports for Samba got updated and everything is running again for me. Fortunately for me, I upgraded at home so a 4 day outage of network shares (for my one windows computer) wasn't a huge deal.

I use the latest binary package repository for FreeBSD. Running FreeBSD 10.3 currently.

I upgraded the FreeBSD to 10.3 but the samba is not working either. Here is the log from samba:

[2017/01/12 22:59:20.835324,  0] lib/util.c:1221(log_stack_trace)
  BACKTRACE: 0 stack frames:
[2017/01/12 22:59:20.835392,  0] lib/fault.c:416(dump_core)
  dumping core in /var/log/samba/cores/smbd
[2017/01/12 22:59:20.835987,  0] lib/fault.c:51(fault_report)
[2017/01/12 22:59:20.836026,  0] lib/fault.c:52(fault_report)
  INTERNAL ERROR: Signal 11 in pid 1039 (3.6.25)
  Please read the Trouble-Shooting section of the Samba3-HOWTO
[2017/01/12 22:59:20.836050,  0] lib/fault.c:54(fault_report)
  From: [URL][/URL]
[2017/01/12 22:59:20.836072,  0] lib/fault.c:55(fault_report)
[2017/01/12 22:59:20.836090,  0] lib/util.c:1117(smb_panic)
  PANIC (pid 1039): internal error
[2017/01/12 22:59:20.858267,  0] lib/util.c:1221(log_stack_trace)
  BACKTRACE: 0 stack frames:
[2017/01/12 22:59:20.858339,  0] lib/fault.c:416(dump_core)
  dumping core in /var/log/samba/cores/smbd
That is true, but I only need the function to share files not any AD needed.
You don't have to enable AD in 4. It'll work as simple file share just like 3 if that's all you need.

About 2 years ago I upgraded a 3.? to 4.1 and used the same configuration file, just removed a few things that were no longer needed. It was pretty painless.
upgraded to

FreeBSD version 10.3-RELEASE-p16

Samba version 4.4.8

It is working fine.

Thanks all.
I've had same problem on a FreeBSD 10.1 system, but the "just upgrade" "solution" doesn't appeal to me.

The problem is that currently samba36 is broken on FreeBSD because of this bug:

You can however, if you have a long running system and use the binary package manager pkg, downgrade the current packages to the last ones that work like this:

cd /var/cache/pkg # This is where pkg stores the packages it downloads
pkg remove tevent # This will also uninstall samba36
pkg install tevent-0.9.28.txz
pkg install samba36-3.6.25_2.txz

Optionally, you can lock the packages to this version until it has been fixed(So that you might do a pkg update/upgrade without having to pick the packages):

pkg lock tevent
pkg lock samba36

Best regards,
Peter, I could hug you.

Had an fine running 10.3 machine with a working Samba 3.6 and did an upgrade to 11.0 just for fun. Bad idea. OS-upgrade worked fine, but the pains to get the services working again...

Been fighting the whole weekend. Last thing to fix was Samba, I'm searching for several hours now why this sh*t isn't working any longer. Your solution did it!


I ran into this problem as well on 11.0. It was odd because I had everything working just fine, but did a recent ports update and that's when samba36 broke for me with smbd core dumping on startup. So, I decided that since Samba36 is kinda old, to upgrade to Samba44, which I am testing now. My setup includes LDAP and PAM support along with legacy Windows 9x and LanMan systems. So far, so good.

I would still like to keep Samba36 until I'm ready to update, but need to figure out where to exclude it from portmaster's update process. I'm not sure if pkg lock will work with ports. ..

Thanks Peter for pointing this bug out!