Solved run_interrupt_driven_hooks: still waiting after XX seconds for xpt_config

submaster

New Member

Reaction score: 1
Messages: 12

Hi everyone !
I'm trying to install FreeBSD on a renewed server, but it fails at the very beginning
I've downloaded FreeBSD-12.1-RELEASE-amd64-memstick.img, put it on a USB stick and tried to boot from it
After initial loader I can see startup process, but after initialization of umass I'm starting to get messages like:
run_interrupt_driven_hooks: still waiting after 60 seconds for xpt_config
run_interrupt_driven_hooks: still waiting after 120 seconds for xpt_config
and so on
I've conducted some experiments - and only option to boot correctly is removing RAID controller, but I need it in my config and it should be compatible with FreeBSD.

My config:
Supermicro X7SBA
Xeon x3330
Adaptec ASR-8405E
Supermicro SC836TQ-R800B case, SAS backplane with expander

Any ideas ?
Thanks in advance
 

T-Daemon

Daemon

Reaction score: 477
Messages: 1,018

There is a PR 209468 concerning the aacraid(4) driver for the Adaptec ASR-8405E, with status "In Progress", patch available, landed in -CURRENT, but apperently not in -RELEASE.
 
OP
S

submaster

New Member

Reaction score: 1
Messages: 12

Thanks for answer !
I've studied link, but found no clue on when will it be implemented ?

Also, I've tried to boot with FreeBSD-13.0-CURRENT - no problem, it can see controller and all disks
But when I've tried to load aacraid.ko as a module to 12.1 kernel - I've got error
 
OP
S

submaster

New Member

Reaction score: 1
Messages: 12

Thank you !
12-Stable works fine, I'll try to figure something out with it
 
Top