UFS Rsync a 365GB folder to a 450+GB (UFS formatted) disk - won't fit

mrjayviper

Active Member

Reaction score: 4
Messages: 172

So I'm trying to backup a folder with subfolders to another disk and it won't fit.

I used rsync -aiv --delete /mysrc /mydest. There are no links (symlinks or hardlinks) of any sorts on the source.

I ran du -d 1 -h on the the source, 1 subfolder is around 195GB but after transferring it to the destination, it now occupies 260+GB according to du -d 1 -h.

As such, I cannot fit 365GB source folder into the 450+GB (formatted size) disk.

Both drives are formatted as UFS. Any ideas on the huge discrepancy?

I've attached a dmesg output for the 2 disks involved.

Thanks a lot :)

edit. I just tried copying another subfolder using cp -av to a new disk (320GB). According to du -d 1 -h, the folder occupies around 144GB on the source. But when I ran the same command on the destination, it uses around 165GB.

 

protocelt

Daemon

Reaction score: 410
Messages: 1,253

You might try using the -H flag to preserve hard links with rsync(1) otherwise you'll have separate files for each link.

I haven't used rsync(1) for some time as I use ZFS on everything now but I think the following command should give you an exact copy of the source on the destination: rsync -az -H --delete --progress --numeric-ids /source /destination

The --delete option should delete any extra data on the destination that isn't in the source and the --numeric-ids option should preserve file permissions on the destination.
 

wblock@

Administrator
Staff member
Administrator
Moderator
Developer

Reaction score: 3,640
Messages: 13,850

It really does sound like links, but mrjayviper said there weren't any. Have the default values for the second filesystem been overridden, so it is using larger blocks or something?
 
Top